Pade 1.7.4-1.7.6 focus user password error

I have been having an issue since Pade 1.7.4 was released. The focus user does not log in and meetings do not start. I found that it is related to the below error in the logs. The error is caused whenthe focus account password contains special characters. I was able to get everything working by not using special characters in the password in a test environment, but I cannot do this in production. Is this a bug or is there a way that I can add the expected quotes so that it will reflect as a string in the application.conf file?

2023.05.13 09:20:03 DEBUG [Thread-117]: org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - Caused by: com.typesafe.config.ConfigException$Parse: /opt/openfire/plugins/pade/classes/jicofo/application.conf: 20: Expecting close brace } or a comma, got '@' (Reserved character '@' is not allowed outside quotes) (if you intended '@' (Reserved character '@' is not allowed outside quotes) to be part of a key or string value, try enclosing the key or value in double quotes, or you may be able to rename the file .properties rather than .conf)

2023.05.13 09:20:03 DEBUG [Thread-117]: org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - at org.jitsi.jicofo.Main.main(
2023.05.13 09:20:03 DEBUG [Thread-117]: org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - java.lang.ExceptionInInitializerError
2023.05.13 09:20:03 DEBUG [Thread-117]: org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - SEVERE: [1] Main.lambda$main$0#50: An uncaught exception occurred in thread=Thread[main,5,main]
2023.05.13 09:20:02 DEBUG [pool-304-thread-2]: org.jivesoftware.openfire.plugin.ofmeet.FocusComponent - (serving component 'focus') Responding to IQ (packetId 611-47) with: <iq type="error" id="611-47" from="focus.rocky.xmpp.ejk" to="component.rocky.xmpp.ejk"><query xmlns="jabber:iq:version"/><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></iq>
    <service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/>
    <error code="503" type="cancel">
    <query xmlns="jabber:iq:version"/>
<iq type="error" id="611-47" from="focus.rocky.xmpp.ejk" to="component.rocky.xmpp.ejk">

I have been busy of late, but I will take a look asap

A have added quotes for Jicofo password in application.conf file. See my test below

Please try this snapshot release to see if it works for you - Release Version 1.7.7-snapshot · igniterealtime/openfire-pade-plugin · GitHub

jicofo {
    sctp {
        # Whether SCTP data channels are enabled
        enabled = false
    octo  {
        enabled = false
        id = 1
    bridge  {
        selection-strategy = RegionBasedBridgeSelectionStrategy 
    rest   {
        port = 8888
    xmpp {
      client {
		 enabled = true
		 username = focus
		 password = "UrpWsxlWJxpU495weoDDi5buQuGZ9R0pSHMvBl0A"
		 port = 5222
		 hostname = localhost
		 domain = localhost
		 xmpp-domain = localhost
		 conference-muc-jid = conference.localhost
		 disable-certificate-verification = true
        client-proxy = focus.localhost
        use-tls = false

That worked. I tried a few different passwords with special characters and they all worked. The focus account had no problems with the password. Thank you for the quick response and fix.

Всем привет.
сегодня тоже попытался установить плагин. Установил последнюю версию 1.7.7
у меня проблема в том что пользователи focus jvd создаются но не активные. и в связи с этим как я понял при авторизации в https://host:7443/pade/
выдает ошибку Your XMPP address and/or password is incorrect. Please try again.