Pade 1.8.1 with Openfire 4.8.1

Installing Pade 1.8.1 with Openfire 4.8.1 leads to a consistent issue where a continuous prompt to sign in is presented anytime I navigate to https://localhost:7443/ofmeet:

Attempting to input credentials leads to the prompt repeating and asking for credentials again (many times). Hitting sign in multiple times (over 10) will some times go to the appropriate ofmeet landing page.

Any assistance would be much appreciated.


Enable anonymouse user access

Or enable Pade to cache username/password in browser

If this does not solve it for you, log an issue at GitHub - igniterealtime/openfire-pade-plugin: A plugin for Openfire that offers web-based unified communications - chat, groupchat, telephone, audio and video conferencing.

Hey Dele!

Appreciate the response. Unfortunately, the recommendations did not fix the issue. I am still presented with the sign in screen and the below message:


Sorry to hear that. Unfortunately, I am unable to reproduce your issue. I have tested both anonymous and authenticated logins and both worked fine for me using OF 4.8.1 with Pade 1.8.1 on my Windows PC

Dear Community,

We have the same issue. After the update PADE is requiring all the time authentication. Our OpenFire is with LDAP authentication for the users and PADE was working until now without any issues with ver 4.7.

I tried all those solutions, unfortunately there is not effect.


As I said before, I am unable to reproduce the issue. I have tested both anonymous and authenticated logins and both worked fine for me using OF 4.8.1 with Pade 1.8.1 on my Windows PC.

Unless someone gives me more useful new information to work with, there is not much I can do

Hey hey,

i check the web requests of the jisi client when opening a meeting, it is unable to determine the token, the /password endpoint returns a html site which is saved in the local storage for a few seconds. The issue we have is that our ofmeet - jitsi thing asks all the time for authentication even though it should authenticate via windows ntlm.

thanks for your help in advance

NTLM. Finally, something to work with. You have said the magic acroymn. I have not tested the SSO (single sign on) integration with Waffle. Considering the pain caused to get Pade working with Jetty 10, this will be no surprise that SSO has stopped working.

I will have a look, but can’t promise anything as my PC is no more part of an AD domain. For now, stay on OF 4.7.5 if that is still working with Windows NTLM SSO.

I think I have found the issue. The /password has been changed to /ofmeet/password as a consequence of Jetty 10, but the Jitsi filter is blocking the URL assuming it is a for a meeting called password.

Try the latest build at archiva or build the latest 1.8.2-snapshot yourself and confirm it works for you. Otherwise wait for 1.8.2 at the end of the month

Thank you, now working :slightly_smiling_face:

If you can fix the other NTLM Pade/Jitsi problem, will be great. →

After windows boot and starting of the OpenFire service, the NTLM authentication is not working and the status of “Jitsi Colibri Focus (Jicofo)” is DOWN. I need every time to restart from the plugins PADE manually to fix this issue… every time after windows update…