Path to embedded database?

Where is the embedded database stored? On a Linux system, which file is it in? I’m getting a “schema does not appear to be installed” error and I’d like to check it out.

The embedded database is a flat file database. I can not remeber where this is installed by default. I would highly recommend moving to an external database.

Hi Jason,

The embedded database files are stored in the directory called “embedded-db” under the Openfire directory.

Hope that helps,


I have two files in there, and openfire.script. I’ve run through the web setup once already, with lynx, and it tells me the schema has not been setup. What should I do? (410 Bytes)
openfire.script (11801 Bytes)

Where are you seeing this error?

I am seeing this error in the web utility, when I try to configure the database system. I tried one time and, as far as I can tell, the server is not working; so I tried again and now I get this error (which I guess would be why it is not working).

It could be a permission issue with linux. Again if this is going to be a production server I would look at MySQL instead. It has good gui admin tools if you are worried about admin of MySQL.

Actually, this tells me something very important – about Openfire. The embedded option is supposed to be the quickest way to get up and running, but now it looks like I’ve got to set up an RDBMS if I even want to try the thing out! If there’s a permission issue, where would I find it? Why is the path to the default database not cleary described in the documentation? On a whole, this is indicative of a fair degree of opacity, and perhaps also of misdescribed feature set.

Yes, the documentation is not full and some parts are outdated (also product descriptions, screenshots, etc.). The community is trying to fill those gaps by creating wiki docs and helping on the forums.

Probably the path of the embedded-db wasn’t mentioned in the documentation, because it is embebbed and the author thought it would be logical to search for it in the installation folder. Just a presumption.

You haven’t specified what version of installation have you used (tar.gz, rpm, etc.) and what linux distribution are you using. Personally, i use a tar.gz version. It’s just an archive, so all the folders are in one place. The user running a setup and Openfire should have write permissions on openfire folder and all subdirectories. Embedded-db folder will be created in openfire folder on the fly after selecting the Embedded DB type in the setup process.

Sure, you can find a software with better documentation or support. This is your choice. Though, Openfire is really a good server with a good set of features and easy web administration.

Todd, maybe you shouldn’t recommend external db so persistently Embedded-db is not so bad. I’m using it for years without troubles and for a small, not critical, production server it’s a good choice.

I would agree with Todd that it sounds like a permissions issue. Make sure that the user that is used to start Openfire has full read/write to all the Openfire directories.