powered by Jive Software

Перестал работать Search

Доброго времени суток. После обновления с версии 4.1 до версии 4.2.3 перестал работать поиск. Плагин поиска 1.7.1. После обновления в админке слетела кодировка для этого плагина, в клиенте, а у меня Spark, тоже выводилось окно с испорченной кодировкой. Удалил плагин, поставил заново. Кодировка стала читаемой, но почему то на русском языке, хотя в настройках админки стоит EN. Вообщем поиск не работает. Помогите разобраться. Сервер крутится на Windows Server 2003 R2, база MySQL. Клиенты тянутся из AD.

Duplicate. Sorry, I used a translator.
Hello. Updated to version 4.2.3 and search 1.7.1 stopped working. OpenFire installed on Windows Server 2003 R2. Base data on MySQL. Users from AD. Help me to understand. Thank.

Could be it (also linked OF ticket) https://issues.igniterealtime.org/browse/SPARK-1873
You can try the latest Spark nightly build to see if it works better (nightly version is buggy, so only use for testing) https://www.igniterealtime.org/downloads/nightly_spark.jsp

Thank. But it’s not about Spark’s client, the search stopped working after updating the Openfire server. Installed spark_2_9_0-20181015-with-jre.exe, as you advised, but the problem persists.

Can I somehow help you to diagnose the problem? Tell me what to do and how. Thank.

I’m not a developer, nor i use AD and MySQL. So I can’t reproduce or test it really. You can check the logs on the server and post them here, you can also try to check what is happening in the client when you try to search (say Spark has a debugger which can be enabled in Advanced menu on Login screen). But i don’t know what you should look for exactly. Then maybe some of the developers could look into this. Although they are few and doing work here in their spare time only.

You can try searching with another client like Gajim, Psi, etc.

Thank :slight_smile: