Periodical server breakdown

Hello everyone!

I am running a private IM service for my High School computers class and am starting to have trouble with it.

It seems that when I go to the administration console it acts like it’'s my first time using it. It asks me to select a language.

I was going to just reset everything when once I finished the Profile Settings of the setup process and clicked Continue it threw an error. A server error 500.


Internal Server Error


Powered by Jetty://

This has happened before. My solution was to drop the database in MySql and reinstall Wildfire. That meant completely remove every last bit of wildfire and then reinstalling. The problem with this is that it is time consuming and my users will have to re-register.

My specs are:

P4 630 @ 3.0 GHz

1 GB RAM (unknown speed)

Roughly 60GB of HDD space spanning 2 drives.

MySQL version: “Ver 14.12 Distrib 5.0.27, for redhat-linux-gnu (i686) using readline 5.0”

Wildfire Version: 3.1.1

I hope someone knows what to do here. Thanks!

This has happened to me before, I assume your running on Linux?

I failed to run the startup scrip as root, (or sudo on some distributions).

everytime I run as a normal user, I got the same error message.

does this help?



It seems that when I go to the administration console it acts like it’'s my first time using it. It asks me to select a language.” - this is a normal behavior when wildfire.xml could not be written - so Wildfire can not store the settings.

Like Jeff also I wonder if you run your server as user “foo” and whether “foo” has the permission to write conf/wildfire.xml and into logs/ or if only root can write that file.


The server is running Fedora Core 5.

This is possible. I do not recall what user I installed it with. But it was probably root as the permisions on my /opt folder are set to RO,

But as I recal, Wildfire uses the user jive to execute and run the daemon. I used the script “” in the folder “/opt/wildfire/bin/extra” after Installed, so ideally all permissions should be correct.

I will try to uninstall it and reinstall as root, is there a way to back up my users? Or will the new setup process overwrite the MySQL database anyway?

EDIT: Found the problem! It was that needed to be run as root. I ran it and everything seems to be back in running order. My computers teacher will be much pleased. Thanks for the help!


Message was edited by: KClaisse

Hi Kyle,

I often wonder how many admins or users have root access to the server they use to install Wildfire. I never use root (and thus never the RPM) to install or update Wildfire. The only root-related things are the /etc/rc-scripts.