powered by Jive Software

Phone and Pulseaudio (Linux 64-Bit)

Hello,

I am seeing the following behaviour on two different versions of the Spark Client:

Spark 2.7.5.752

Audio device shows up in “Media settings” as

javasound:default [default]: 0

In Pulseaudio mixer I can see a seperate connection from Spark (shown as ALSA plug-in [java]) for every phone call I make, which is probably unnecessary. Otherwise it seems to mostly work correctly.

Spark 2.7.7.810

After logging in, console output shows a stracktrace starting with

SEVERE: Failed to register custom Renderer org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with JMF.

java.lang.IllegalStateException: audioSystem

Only interface shown in “Media settings” is audiosilence. No sound at all.

As i saw Jitsi mentioned in the Stacktrace and I have it installed I tried that (latest nightly), and it worked flawlessly with Pulseaudio.

Possibly useful info about my system:

Debian GNU/Linux testing (stretch)

pulseaudio
8.0-2+b2
amd64
PulseAudio sound server

I’m grateful for any feedback regarding the topic. Thanks!

Did you ever solve this problem?

I guess 2.7.5 was the last version before one of the contributors to the project attempted to merge the libjitsi patch (which was started by yet another contributor, but never finished). It didn’t worked, but on the other hand fixed a few seemingly unrelated issues on Mac OS X. As the audio was still broken with or without that patch, we decided to leave it as is. At least it has fixed a few other issues. Patches are welcome as audio\video part is very complex.

I also learned that older versions of libjitsi was ok, and according to this article Jitsi - FreeBSD Wiki , the said the audio was broken, I am hoping to find one of the earlier releases of libjitsi, if you can direct me to an archive that would be good.

thanks!