Phone Mapping takes over desktop IP Phone when spark logs on

I would like to have the phone call functionality and prompts that Spark normally displays when a call comes in, but I don’t want the softphone to take over my normal dekstop IP Handset. If I take out the Phone mapping the Spark client phone stops working, along with all of the prompts etc when a normal call arrives at my IP phone. However if I leave the mapping enabled as soon as I start Spark it does a new SIP registration in Asterisk and my IP phone can make calls but not receive them, as they go to the Spark softphone.

Is this available or does anybody have any ideas on how I might achieve this.

Many thanks, Brett