powered by Jive Software

Pidgin 2.13 and OpenFire 4.2.3 can't connect

I’ve searched and searched and can’t find an answer. I have a new Openfire 4.2.3 installed on Windows Server 2016. I’m running Pidgin 2.13. I can’t get Pidgin to connect. I’m running LDAP and the Openfire server sees all of the users in my domain. When I run Pidgin in debug, I get:

Blockquote

(12:45:40) dnsquery: Performing DNS lookup for openfire.x.x.x.x
(12:45:40) dnsquery: IP resolved for openfire.x.x.x.
(12:45:40) proxy: Attempting connection to
(12:45:40) proxy: Connecting to openfire.x.x.x.x:5222 with no proxy
(12:45:40) proxy: Connection in progress
(12:45:46) util: Writing file accounts.xml to directory C:\Users\x.x\AppData\Roaming.purple
(12:45:46) util: Writing file C:\Users\x.x\AppData\Roaming.purple\accounts.xml
(12:46:01) proxy: Connecting to openfire.x.x.x.x:5222.
(12:46:01) proxy: Error connecting to openfire.x.x.x.x:5222 (Connection timed out.).
(12:46:01) proxy: Connection attempt failed: Connection timed out.
(12:46:01) jabber: Couldn’t connect directly to openfire.x.x.x.x. Trying to find alternative connection methods, like BOSH.

Blockquote

I previously had an old Wildfire Server up but ran into some certificate issues, so I tried to build a new server. Firewall should be all set to allow traffic due to having a previous Wildfire server up.

What am I missing?

You can try disabling firewall for a moment. If firewall rule was setup from a popup it ties a rule to an executable, which has changed as you have installed the new version. It is always better to create rules manually and set them to specific ports instead of executables (although you can still do that if you need even higher security).

Also, you can also check Openfire error log.

Tried disabling the firewall. Still got the same error. Openfire error log shows me:

org.jivesoftware.openfire.spi.MINAConnectionAcceptor[socket_c2s_ssl] - Error starting: 5222

I actually got the above error to go away. But I’m still getting the timeout error when trying to connect in pidgin

The above error said the port is not available. If you fixed this, what error is logged now? Btw, try some other client to rule out issue with Pidgin. Maybe other client will show some useful error (try Spark with debugger enabled or Gajim, Psi).

I do not get an error on the Openfire server now. It’s just the connection timeout on the Pidgin client and I get an unknown connection error when using Spark. How do I run Spark with debugger enabled? I can’t get that one to run in debug mode.

To start Spark with debugger on its login screen go to Advanced and check the debugger checkbox. Though Spark is still logging logs anyway. You can find them in C:\Users\User\AppData\Roaming\Spark\logs
There are a bunch of files, look through all of them and select events that correlate with the time you are trying to login.

If error is unknown, it seems that your client can’t reach the server for some reason. Maybe you are trying to login with your server’s name, but this name is not in DNS or any other local name resolution, so the client’s PC can’t understand where to connect. Spark’s error log should show DNS related errors in this case.

Ok, I’ll give the Spark debug a shot. One other thing to note is that if I install Pidgin on the server where Openfire is installed…it works fine. Pidgin and Spark just can’t connect anywhere else. I can also see the name of the server in DNS.

I basically get the same thing from Spark.

Nov 07, 2018 11:48:20 AM org.jivesoftware.spark.util.log.Log error
SEVERE: connection error
org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: 'OpenFire.x.x.x.x:5222' failed because java.net.ConnectException: Connection timed out: connect
	at org.jivesoftware.smack.SmackException$ConnectionException.from(SmackException.java:255)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectUsingConfiguration(XMPPTCPConnection.java:612)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectInternal(XMPPTCPConnection.java:850)
	at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:364)
	at org.jivesoftware.LoginDialog$LoginPanel.lambda$login$1(LoginDialog.java:1099)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Is this your Openfire server’s name “OpenFire.x.x.x.x”? I guess the x stands for IP address. And you are putting this “OpenFire.x.x.x.x” into Spark or Pidgin as domain? Is this “OpenFire.x.x.x.x” as an entry in your DNS pointing to the machine with Openfire installed? Can you ping that name from the machine with Spark/Pidgin? If you can ping, you should be able also to telnet to that name on port 5222. If you have this in DNS and can ping it, but telnet doesn’t go through, then it looks like a firewall issue. Although you said it is off.

Ok, now i feel dumb. Before I was just turning the Windows Firewall off on the endpoint. But once i turned the Windows Firewall off on the OpenFire server…bingo. I can connect now. Thanks for your help! I appreciate it!

Never mind :slight_smile: As i’ve said, you can just manually create a rule to let incoming connections on TCP 5222.