powered by Jive Software

Pidgin 2.5.5 + Openfire 3.64 +Ubuntu 8.04 = Not Authorized

I’ve seen this problem of the forums. Ive tried the xmpp.fqdn thing in systems properties but it did not work.

I dont have a domain name, this is strictly for a LAN

So the machine has an address of mymachine.local

I’ve set that in pidgin. But I can’t chat with other users and none of them can chat with each other. There is a not authorized msg in the pidgin window.

Is there anything I can do to get pidign to work with openfire?

Thanks.

If you clients cant resolve your server’s name, then try using its IP address instead when specifying th server to connect in Pidgin settings.

Hi I tried this and it does not work.

The thing is I tried spark and spark worked I did’nt even have to use an IP. use the local name of the server (myopenfireserver.local).

Should I be filing this as a bug with the pidgin website maybe?

Can you provide more information? With pidgin -d you can enable debug output (to STOUT) and on the admin console of openfire you can look to the logs (at least the error and warning logs). I use Pidgin and Openfire (with Debian and other distros, but should be very similar since Ubuntu uses many Debian packages) without your described problem.

Best regards

I’m exicted to know then that it works with pidgin!

I am wondering if its because I am just using it interally and have no CA signed certs. This is just the default self-signed certs. I have enabled debugging and will post some logs shortly to see if they make any sense.

P.S. is there a way to get the pidgin -d output into a file…this is quite a bit of info scrolling off the terminal window.

Here are the logs and how i came about them…

I cleared the logs in openfire then rebooted.

I then open pidign with -d option and logged into user.

I’ve attached them as a txt file…
openfire.log.txt (17275 Bytes)

Ok, according to your logs there is no problem .

A little bit more serious, the errors in the Openfire logs imply that your file proxy setting in Pidgin is wrong, it should be proxy.fshopenfire.local but that isn’t the problem.

You’re XMPP connection between Openfire and Pidgin is well established and now I’m getting an idea what your problem is. The user can’t setup their Buddy list. I also noticed some problems with this, but somehow it works. I tried it several times (when both users are online) and in the end it works. Another workaround could be try to setup the buddy list with another client. But you’re right there is a bug. I will try to debug and find the problem.

I dont have a subdomin called proxy.fshopenfire.local. Should I just use in that field fshopenfire.local?

Thanks.

You don’t need a subdomain that handles Openfire for you since it doesn’t need to resolv this name. A subdomain is only necessary if you provide this proxy for other XMPP servers. But the client first try to connect each other directly before they use the proxy for file transfers. But anyhow this is only for filetransfers and not for chat.

Hmm, sorry, I noticed that problem before but now I can’t reproduce it, all works fine. Maybe I’ve a fixed version of Pidgin or Openfire, so maybe another Ubuntu user can help you.

What version of pidgin and openfire are you using and on which OS and version.

I replaced the self-signed certs with CA signed certs on the off chance this was the problem but same issue no cigar there.

A pic is worth a thousand words.

I build Pidgin from the 2.5.5 sources (with some third party plugins) and the actual svn version of Openfire (with some modifications but none of them deal with this problem). The certs don’t affect your problem. Certs are only for a secure connection to your server (and your connection is great!). Delete the buddy entries and try again to add them while both are online (I think that was my workaround for that problem before).

Hi again,

I think I see my problem.

When adding a buddy, i just typed the nickname. But I tried adding nickname@domain.tld and that worked.

Have you come across the problem where after the person authorizes a buddy the add buddy dialog pops up and you go ahead and add…but the requesting user is listed twice in the autorizers pidgin window?

Ok nevermind … pidgin bug to be fixed in 2.6.0 i believe.

http://developer.pidgin.im/ticket/479