PLUGIN: requires server version 3.9.4


I’ve installed OpenFire 3.9.3 ah hit probably common problem.

I’m trying to install xmldebugger plugin, but it checks for 3.9.4 OpenFire version, which is not released yet.

I’ve searched for older versions, but without success. Can anybody advice where to look for older versions of plugins, cause “xmldebugger” is not the only plugin with 3.9.4+ requirements (ofmeet: requires server version 3.9.9).

You can checkout from GIT

GIT URL Openfire/src/plugins/xmldebugger at openfire_3_9_1 · igniterealtime/Openfire · GitHub

But you need to compile it and create the war file or jar file

Unfortunately, you are seeing a current gap with our Ignite infrastructure. You are sort of stuck unless you compile old code trees yourself. We will fix this someday.


Is 3.9.4 coming soon?

No, 3.10.0 is not far away though.