Plugins doesn't show in the spark

It seems that my plugins can’t be realized by the spark.

I had just imported two plugins into the spark but can’t see them. Then I found the fastpath didn’t show up, even in the plugin management in spark I cannot find the fastpath plugin neither.

I’ve tried to re-install the fastpath, the spark even the openfire. But they don’t work.

I hope someone can help me, please.


Spark: 2.6.3

Openfire: 3.7.1 & 3.7.0(I’ve tried twice with two editions)

OS: Win7 64-bit

What are these two plugins you are trying to import? Are they written by you?

Fastpath plugin should already be in Spark, no need to install or enable it. It will show up as long as user logged in is a member of a fastpath queue, is an agent. Fastpath plugin should be installed on the Openfire for queues to configure and to assign agents to them.

Thanks for your reply.

The two plugins, one is a simple tab I wrote for testing. The other is the example supplid by the JIVE. I tried to packaged it to use as a plugin.jar, but they all don’t work. I don’t know why.

I have seen the fastpath jar in the plugin file of the spark and the user logged in is a menber of a fastpath queue. But the fastpath doesn’t show up in the spark.

About the Fastpath tab in Spark. Go to Spark > Preferences > Appearance and make sure Show conference service in tab is selected (restart if needed). Fastpath tab won’t show up if this option is not selected. A design bug. Can’t tell anything about the other plugins or examples from Jive (Jive examples are probably too old for the current Spark version).

wroot is correct , the JIve examples needed rework. For an example, you may use the plugin with the revesi game. This works for sure with 2.6.3.

Oh…I have deleted the examples and selected this option. In fact, I have reinstalled the whole spark. But it doesn’t work yet.