powered by Jive Software

Plugins Updating problems (3.0.0)

I know that 3.0.1 is out, but i will upgrade at the end of work day. I found new user Import Export plugin (it says it was updated for 3.0.1 but it doesnt warn it’'s not compatible with 3.0.0). But that would be ok if Admin Console would warn about this, but it doesnt.

BTW, there should be Update Plugin List button in Current plugins page too, not only on Available plugins page. So i have updated plugins list and update for user Import Export plugin showed up. No warning that it’'s not compatible. So i tried to update and it got stucked in a loop. Then i tried to click somewhere else and got javascript error JM-741 which is fixed for 3.0.1. Then i went to Logs and saw in warn.log:

2006.07.14 08:44:18 Ignoring plugin userimportexport: requires server version 3.0.1

The worsest part that Wildfire has deleted older plugin version. Why? If should check if it can update first and only then delete. So now i dont have older plugin, and i cant install newer until i upgrade Wildfire, so i cant backup my DB.

I hope all of this will be fixed soon.

One more thing. In Updates Management i have enabled notification of admins about updates. I have system property xmpp.forward.admins with wroot@myserver. But i didnt get any message. I thought it should.

reposting some part

http://www.igniterealtime.org/forum/thread.jspa?threadID=26460