powered by Jive Software

Port 5222, 5223 not open after UBUNTU upgrades


#1

I recently upgraded the Ubuntu server housing Openfire. Server is 18.04. Openfire is 4.2.3. Clients can no longer connect.

I checked via netstat and see that there is nothing listening on 5222, 5223, but the admin console is fine on 9090. I have seen some chatter that there could be a problem with Java. Admin console shows it is using 10.0.1. I have tried using “update-alternatives” to choose other Java versions, but no matter what I do, the console shows 10.0.1. Is this the problem, or am I missing something else? If this is it, how do I make openfire use a different version of Java (it shows several are installed).


#2

Yes, if you’re using Java > 8 you’re going to have problems. https://issues.igniterealtime.org/browse/OF-1383

You may be able to force Openfire to use Java 8 by setting the env variable JAVA_HOME to point to a Java 8 installation. Have a look in /etc/default/openfire (I think - I’m not familiar with an Ubuntu installation).

Greg


#3

That was what I was looking for. I set it to look at Java 8, and one problem is solved. Now it will listen on 5223, but still not on 5222. I have tried Oracle Java 8 and JDK 8. Both will allow 5223, but neither will open 5222. Am I missing something else?