powered by Jive Software

Post upgrade 4.x problems

Hi,

we ran an upgrade with DB migration. (3.8 to 4.13 to 4.22)

New setup: Server 2008R2, w/ Java 1.8.0_121 and SQL 2017, AD LDAP Authentication

we use the following steps

  • Step 1. Backup/Restore DB to new SQL server (higher version)
  • Step 2. Ran OF 4.13 Setup, pointing to same database - No errors, all plugins are working, seems to be good.
  • Step 3. In place upgrade to 4.22 - No issues.

Next day we noticed two problems with MUC

Problem 1:

Group Chat / Service Options/ Administrators:

Tying to add - no problem, try to delete using red X - "Error adding the user/group. Please verify the JID is correct. "

Problem 2:

Some Rooms, when you click on Permissions output:

java.lang.NullPointerException

	at java.net.URLEncoder.encode(Unknown Source)

	at java.net.URLEncoder.encode(Unknown Source)

	at org.jivesoftware.openfire.admin.muc_002droom_002daffiliations_jsp._jspService(muc_002droom_002daffiliations_jsp.java:460)

	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)

Any help is greatly appreciated.

First one is a known bug since 4.1.1 https://issues.igniterealtime.org/browse/OF-1488

NPE problem Solved:

Using information from Java Error in Group Chat Permissions

I noticed 2 problems for group in question.

Problem 1: ofMucMember table has 36 users while room maximum was set to 30. I increased room size but NPE problem persist.

Problem 2: Some user’s names were misspelled.

Initially I tried to delete misspelled names from database, but that did not help.
Correct solution was to edit user names in table. Since some users had misspelled and properly spelled names, I use some random existing user (not from Owners or Administrators)

After restart Permission tab start working, and I was able to delete “modified” users using console.