Presence not updating

I’‘ve tried the following on both 2.3.1 and SVN (Sunday, December 11th). I’'m running this on Ubuntu 5.10 with the latest Sun JDK using the embedded-db.

I’‘ve written a small plugin to add users to one of several shared (by everyone) groups based on their IP address. The users are authenticated against LDAP (eDir, to be exact). When a user logs in, they see everything that happened up to that point. If someone is currently marked as away, they see them as away. They do not, however, see anything after that point in time. A group can be created at login if no one is in it yet. If that’‘s the case, they don’'t see the created group. If someone is already online and they change their status, they will not see it, nor will that user even see that the newly logged in user is in fact online.

The logs don’‘t produce any information on this, nor does Spark. In the debug log, I only see presence updates that I didn’‘t point out above as being missed. It’'s the same with Spark. I do not see any packets of logins or presence updates after I log in. I can converse with these supposed logged off people just fine though. As soon as I log out and log back in, I see everything I missed.

The admin console sees the correct presence information all the time.

I’‘ve search around the forum a lot, but have come up with nothing. As I said, I tried svn, I tried adding “cache.username2roster.size”, which probably wouldn’‘t make sense here anyway. I don’‘t think this is related to the other LDAP not updating groups bug as I’'m not using the LDAP group provider. These are local db-created groups. Does anyone have any ideas?

Message was edited by:



I have the same problem, and it’‘s not Spark specific. It’'s any Jabber client connected to Wildfire. I just updated to Wildfire 2.6.2, and the problem is still there.

I used Exodus on Windows and Gaim and Kopete on Linux. The initial presence notification works. But any presence updates are lost past the server, they never reach the clients. This is for Shared Group only, Individual Subscription work fine.

Message was edited by: mhuysamen

I’'m seeing the same problem. Everything is accurate at the moment I log in. Nothing ever updates though when other people change status or go offline.

Wildfire 2.6.2, Spark 1.1.4

Message was edited by: parseljc

Hey guys,

Could you check in the XML debugger window the iq:roster packet that the server is sending to the client after logging in? Some clients provide a window to get that information. For instance, in Spark, Exodus and Pandion you can press F12 to open that window. Once you got that info post it here together with your server/LDAP configuration. A common error is that LDAP integration is not using posixMode so presences are never received.


– Gato

I did not have ldap.posixMode defined in my wildfire.xml file because the documentation says the default is false. I went ahead and added it with a false value and restarted Wildfire. Still don’'t get any presence updates after initial login.

I’‘m not sure what you mean by “iq:roster packet”. At login there are lots of lines with IQ Received / Sent (class=org.jivesoftware.smackx.packet.DiscoverInfo / DiscoverItems). I don’'t see the word “roster” anywhere here. What should I be looking for?

(This is with Spark 1.1.4.)

Here is my LDAP config:

                    (memberOf=CN=XMPPaccess,OU=Group Groups,DC=group,DC=company,DC=parentcorp,DC=local)


Wildfire 2.6.2 is running on RHEL4.

LDAP is Active Directory on Windows 2003 Server.

Message was edited by: parseljc

Same thing for me. OS = slackware 10.2, clients = latest spark

no ldap integration.

We are having the same problem here, and it doesn’‘t matter what client we use either. (We have tested over 5 clients and the problem doesn’'t change.)

We are using Wildfire 2.6.2 and Spark 1.1.4 (as primary client) in an entirely Windows environment.

The problem looks to be something with the Wildfire server and how it handles notification of client activity… but I could be entirely wrong.

The server recognizes when a user signs on or off, but it doesn’'t pass that information on to the people who have that user in their buddy list.

I am a new user to wildfire/spark and I was also having the presence update problem. In our test group we had 10 people, were authenticating to LDAP(AD), and were trying to push the AD groups to our users. All would be fine when they logged in, but they would not get updates for some user some of the time. I had seached this fourm and tried all the suggestions (posix mode, LDAP config problems, manual groups, logging in ond out to update presence, ect…)none seemed to work. after removing all the groups on server and having all users go through the invite/accept procedure and create their own groups, all has been working great. While I really wish the centralized roster groups would work, with < 100 users it not a show stopper… Coluld the problem with the groups be something with not doing the invite/accept thing?

We’'ve been testing Wildfire 2.6.2 and the latest Spark client. We too had the same issues as mentioned here. I seem to have found the bug as I modifed our 10 test users in AD so that their “common name” value did not have a comma. For example, a user named Joe Smith had a cn=Smith, Joe[/b]. I modified it to be cn=Smith Joe[/b]. All I did was remove the comma and left the space there.

Now all the test users get updated Presence info, such as users logging off or AD group mods in the Roster. The only negative issue is that all users can be seen now without a comma, which for some people may not be a big deal.

I made these AD mods using the “ADModify” tool which is explained here:

We’'ve seen no negative results from removing the comma, including in Exchange 2003. Our GAL display name still shows with a comma, which is desired.

I’'m hoping this so -called bug can be fixed so these commas can be added back in, although this workaround is helpful.

Good info! I can confirm that removing the comma in AD fixes the Presence problem. All our users are listed as “Lastname, Firstname” in Active Directory. I removed the comma for myself and one other user. (I just logged into my domain controller, right-clicked on the user and picked “Rename” to remove the comma from the displayed name. This removes it from the cn and also from the distinguished name as viewed from Softerra LDAP Browser. The comma is still there in the displayName.) Now we get updated presence information when each other signs in or out or changes status.

I guess we need a developer to file a Bug report since this is easily reproducible.

Hopefully it’‘s an easy fix. We consider this a showstopper and won’'t deploy it if presence is not working. Removing all the commas (and all the forward slashes- JM-695 ) is not an acceptable workaround. We would like to see Wildfire support all the possible characters that Active Directory allows when naming users.

I have the same problem with wildfire and the embedded data base.

How can i fix that problem?

thank you


I’‘ve got the same problem, but have a work around to fix it, but ideally I don’‘t want to use the work around. I’‘m using OpenLDAP 3, Wildfire 2.6.2, Suse 10. Again my precense isn’'t updating.

Anyway my buildup to my workaround: lately we just started using the search filters (for groups and users) in the config file since we want to filter out some groups from connecting to the server. The moment I put the search filters everything worked fine, except the presence wouldn’'t update. I removed all the search filters from the config file and the presence updating fixed itself again.

Here is my config file:

          <GIVEN attrs="givenName"></GIVEN>


We are working with this for the time being, however, it would be great if we could sort out the problem and filter out unwanted users.

I’'ve read the above posts, and am not sure if theres a difference between AD and Openldap. Currently my users DN are as follows:


So there is no comma’‘s in the name, although it could be the fact that there is a ‘’.’’ in the name. II must try this. Either way hopefully this will help fix the problem

If its any help to anyone, I’‘ve worked out a workaround for the problem. It turns out the groupSearchFilter isn’'t working properly, and this caused the presence not to update.

I’'ve fiddled around with the groupSearchFilter and found out that my previous groupSearchFilter: ($(cn=)(objectClass=groupOfNames)(!(cn=customers))) causes the problems.

I’'ve changed the groupSearchFilter in my config file to:

(|(cn=itstaff)(cn=group1)(cn=group2)(cn=group3)) and this seems to fix the problem.

In response to my previous post, I suspected that the ‘’.’’ in the uid caused the problem (since it is a special character), but this was not the case.

Hope this helps somebody.