powered by Jive Software

Presence Subscription Trouble

IWe’‘re newbies to Jive Messenger and Jabber, and are looking for advice. We’'re having a devil of a time getting presence subscription requests to be exchanged.

We’'re running JM 2.2.2 configured to use our LDAP server for authentication. Users can IM each other without problem, and presence status shows up fine on the admin console. And users show up and can see each other in conferences.

The problem comes with the presence subscription handshake. Adding a new contact works in all the clients we’‘ve tried, except that the subscription request doesn’‘t show up at the contact’'s client, so they just stay in “pending” status, and no subscriptions happen.

I’‘m sure we’‘re got something misconfigured or are otherwise missing something simple, but we’'re definitely stumped right now.

Can anyone advise us on what ot check next?

Thanks,

–Webb

Here are some details.

With the Exodus debug log on, there is simply no message received at the new contact’'s client when it appears that the request should have been sent.

Exodus says that the appropriate message is sent to JM. I can’‘t figure out how to cut and paste from the Exodus debug window, so I won’'t hand type the whole thing…but it does report that it sends

Hey Webb,

Do both users belong to the same server? Or are you trying to add a user of a remote server to your contacts list?

From your last XML I would say that there might be a domain problem going on here or a server-2-server issue…

It seems that your server name is 127.0.0.1 and the user "user@127.0.0.1" tried to add "newcontact@aptima.com" to his roster. Since aptima.com is not the name of your XMPP server then Jive Messenger will try to generate a connection to a remote server whose name is aptima.com. That means that server-2-server is being used. If you wanted to add someone from your server then instead of using "newcontact@aptima.com" you should use "newcontact@127.0.0.1". However, if you wanted to add a remote user to your roster then you have to make sure that the port 5269 is opened in your firewall and that a connection to the remote server was successful. You can enable the debug log to obtain more information during the s2s handshaking.

Regards,

– Gato

That was it.

We originally told JM the server name was 127.0.0.1. Telling JM that the server name was "server.com"which is actually our domain namedid the trick.

Thanks!

–Webb