I am getting following error as soon as i updated my openfire verison. i never had this issue before.

2024.05.06 07:10:47 org.jivesoftware.openfire.PresenceRouter - Could not route packet
java.lang.IllegalArgumentException: No enum constant org.xmpp.packet.Presence.Type.available
at java.lang.Enum.valueOf( ~[?:1.8.0_202]

My client is a ngx-chat library and on the client library i am getting following

> <iq xmlns="jabber:client" type="error" id="343fef27-5f62-4a78-bf8e-20852860921f:sendIQ" to=""><query xmlns="urn:xmpp:mam:2"><set xmlns=""><max>250</max><before></before></set></query><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"></service-unavailable></error></iq>

Can anyone please tell me what it could be ?

These are two different problems:

In XMPP, a “presence” stanza (which is a type of data packet) has an optional type attribute. The list of valid type values is defined in the XMPP specification. The value available is not a valid value for this attribute, yet someone on the network has tried to use it.

Typically, a client should be modified to not send a type value at all, when the status of “available” is intended to be expressed. This absence of a type is interpreted as ‘being available’.

The seconds error is returned to the client after it tried to query a message archive on an address where such archiving functionality is not available. This could have a number of reasons: the addressing might be incorrect, or the service is not installed (eg: for Openfire, the Monitoring Service plugin needs to be installed and configured correctly for this service to be available).

I hope this helps!