powered by Jive Software

Privacy list get broken?

I can’t get the privacy list call to return anything even though privacy lists exists. Here’s what I see when I do a get:

<iq type="get" id="aad3a" >
    <query xmlns="jabber:iq:privacy"></query>
</iq> <iq type="result" id="aad3a" to="psi@localhost/pkang-mac" >
    <query xmlns="jabber:iq:privacy"></query>
</iq>

This is always true even after calling set, like:

<iq from='psi@localhost/xxx' type='set' id='edit1'>
    <query xmlns='jabber:iq:privacy'>
        <list xmlns="jabber:iq:privacy" name="public">
            <item action="deny" order="100" type="jid" value="spark@localhost"></item>
        </list>
    </query>
</iq>

I get a successful response from the server and have verified that the privacy list entry exists in the database. I can activate a privacy list, but ‘get’ always fails to return a list.

Is this a bug or am I doing something wrong? I’m using Openfire 3.4.1 on a Mac.

pablo

Hi Pablo,

you may want to add “from=‘psi@localhost/xxx’” to your get query, this should fix the problem.

LG

I tried that but I get the same result. :\

Hi,

for me Privacy Lists works fine, hopefully it helps also you.

LG