powered by Jive Software

Privacy List not working correctly


#1

Hy there,

I am trying to make use of the Privacy List specification (XEP-0016).

The specification says the following…

If the type is “jid”, then the ‘value’ attribute MUST contain a valid Jabber ID. JIDs SHOULD be matched in the following order:

  1. <user@domain/resource> (only that resource matches)
  2. user@domain (any resource matches)
  3. <domain/resource> (only that resource matches)
  4. (the domain itself matches, as does any user@domain or domain/resource)

However, I can’t get any of these matches to work. The only way that this works for me is when I use mucRoom@domain/userName.

What I am trying to do is, as an user, be able to block incoming messages from another user.

Let say I have user bob and user andy. I want to block all messages that goes from andy to bob so from bob’s point of view it would be as andy doesn’t exist. An d I want this happening on all rooms where bob and andy could be present.

So far I go it to work but only to individual rooms using this match… roomName@chatServer/userName

I could add a rule for every room we have but that won’t be good as more rooms get added, I will have to go though all privacy lists adding new rules.

Can any of you add some knowledge here please?

I also tried to achieve blocking user by creating a groupe where I add the users I want to block, andy in this case, and setting my rule to block messages from that group but this din’t work either.

Thank you very much in advance to all of you.


#2

OF-846 is linked to this post.