powered by Jive Software

Problem after Upgrade to 4.0.3

I’ve tried to update from 4.0.2 to 4.0.3 on CentOS 5. RPM seemed to install normal. Starting the service with /etc/init.d/openfire start said Starting Openfire… but then nothing appears behind. (no OK, no failed).
Has anybody an idea what could be wrong?

Look at the log files in /opt/openfire/logs and see if anything is interesting there, nohup.out there may have some clues too

The logs entries end at the point of update. Only the nohup.out says:

/opt/openfire/jre/bin/java: /opt/openfire/jre/bin/java: cannot execute binary file

what happens when you run this as root

/opt/openfire/jre/bin/java -version


sudo /opt/openfire_new/jre/bin/java -version

/opt/openfire_new/jre/bin/java: /opt/openfire_new/jre/bin/java: cannot execute binary file

I renamed the new installed folder to get the previous version running.

Should I replace the java file with the 4.0.2 java file?

I installed a Centos 5 VM today to test this and can’t reproduce.

[root@localhost ~]# cat /etc/redhat-release
CentOS release 5.11 (Final)
[root@localhost ~]# /opt/openfire/jre/bin/java -version
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

OH NO, 64bit server version of java! Darn, that’s what is wrong. sigh

Ok, the available RPM has been updated to include a 32 bit JRE. Sorry for this trouble

[root@localhost tmp]# /opt/openfire/jre/bin/java -version
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) Client VM (build 25.102-b14, mixed mode)

Works like a charm now!
No problem. Thank YOU for your great work

1 Like

Unfortunately I had already downloaded an RPM from August 17th and without a version bump, I didn’t realize it wasn’t a current build.

Ended up having to revert to the former version. Later I found this thread. :wink:

I was fortunate to manage maintenance time today and the upgrade went smoothly.

I’ve been waiting a bit between ghost sessions regarding OF-829 and my schedule, but it all worked out!

So far running like a champ.

Thanks for your effort and allowing us to use your software.

Thanks @Daryl Herzmann and @David for posting.

  • Mike