powered by Jive Software

Problem connecting to gtalk

I am new to the transports, so I am probably missing something easy, but here goes.

I am trying to setup a transport to google (not the normal jabber federation, but using an im gateway).

I installed the gateway plugin , turned on the gtalk transport and ran the test for gtalk (connect to the server), that worked fine. I didn’t do any other setup.

I then tried to register using the spark client (using the icon at the top).

I eventually got back an error that said I had an invalid usernmae/password.

I then traced the calls from my openfire server to talk.google.com and here is what I see.

First my server (which is behind a firewall and has port 5222 open to talk.google.com) , connects to google and trasmints these packets:

<stream:stream to=“gmail.com” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

<?xml version=“1.0” encoding=“UTF-8”?><stream:stream from=“gmail.com” id=“FF8F2C2CDA58DB07” version=“1.0” xmlns:stream=“http://etherx.jabber.org/streams” xmlns=“jabber:client”>

(So far so good)

Google then responds with:

<stream:features><starttls xmlns=“urn:ietf:params:xml:ns:xmpp-tls”><required/></starttls>&l t;mechanisms xmlns=“urn:ietf:params:xml:ns:xmpp-sasl”><mechanism>X-GOOGLE-TOKEN< /mechanism></mechanisms></stream:features>

Then my openfire server sends:

<starttls xmlns=“urn:ietf:params:xml:ns:xmpp-tls”/>

After that google tears down the connection (sends 2 RST packets)

Does anyone know what I need to setup or do to get this working?

Should I giveup this route and go with jabber federation?

Thanks in advance

-Kevin

I believe this is a duplicate message and should be deleted or at the very least closed out.