powered by Jive Software

Problem getting SVN to work

I am trying to download the Spark code so I can make a small change and then push it out to our internal users…

I tried the instructions which say to use:

svn co http://svn.igniterealtime.org/svn/repos/spark/trunk spark

When I use TortoiseSVN from a command prompt, I get:

C:\SparkCode>svn co http://svn.igniterealtime.org/svn/repos/spark/trunk spark

svn: Invalid config: unknown HTTP library 'http://svn.igniterealtime.org/svn/rep

os’

Sooooo, what am I doing wrong???

I use RapidSVN and i just put http://svn.igniterealtime.org/svn/repos/spark/trunk as URL in the Checkout dialog

I just tried RapidSVN, and I have the error message attached…could it be a firewall issue? Are there specific ports that need to be opened in order to connect???

http://imageshack.us/photo/my-images/535/svnsy.jpg/

When I try with just the URL of http://svn.igniterealtime.org/svn/repos/spark/trunk

And I’m getting this with RapidSVN:

Execute: Checkout

Error: Error while performing action: Invalid config: unknown HTTP library ‘http://svn.igniterealtime.org/svn/repos

Ready

Well, there shouldn’t be any firewall issues as you are connecting to the svn, not vice versa. It’s strange that you get same error with both program though. RapidSVN works fine for me with that URL, just checked in a virtual machine, fresh install.

Since you have access to it, would it be possible for you to .zip up the files and email them to me???

I’ve got a office full of people waiting to use OpenFire, and Spark is holding me up

Well, thats over 100 MB, so email is not good for that I have uploaded it to my hosting. I believe it’s build, documentation and src folders that you need.

http://www.wroot.lt/jive/Spark.zip

Thanks so much! Now I just need to find the setting for the default server port and server name are stored, so I can compile and push out to my users…

You can hardcode servername via default.properties file (host_name) http://community.igniterealtime.org/docs/DOC-2163

There is no port setting in that file.

Yea, I need both set before I push it out…we have people outside of our office who I am going to send the installer to, and I need it to work for them, without having to modify files…

These are generally not computer-savy folk

Or are you saying there isn’t anyplace in the source code to set the port to use automatically??

I don’t know. Probably there is such place.

To specfiy the port, you can add it in the HOST_NAME like “HOST_NAME = chat.mydomain.com:5888

The port in the hostname will override the XMPP Port specification in the preferences-Login window and in the Advanced window…

The only disadvantage is that the hostname is displayed as is (with the port) in the login window of spark

Under windows XP, create a spark.properties file at C:\Documents and Settings\Administrator\Application Data\Spark and add the settings you want your user to use:

xmppHost=ip.adress or chat.mydomain.com

hostAndPort=true

xmppPort=5333

server=chat.mydomain.com

These values will be read first when spark is launched.