powered by Jive Software

Problem in installing Openfire

Hi,

I’m new here,

The Operational System used is Windows 2003 SP2 and version of Openfire is 3.8.1,

I chose Internal database and Directory Server(LDAP)

during installation in step 1of 3(Configuration Profiles: Connection Settings) I fill all the fields, and click on the test button but nothing happens, except that the page refreshes(no message appears), and still continue with the following steps,

the step of adding an administrator returns an error(No User informed, or informed the User was not found), I believe it is because of the test was not successful.

I use firefox(21) but I tested with other browsers also and nothing changes.

Thanks!

  1. are you sure that the user you add exist in LDAP?

  2. if you want to add xxx@abc.com, you should change @ to \40

The test did nothing for me either, but if you go through to the next steps the page to add adminsitrator users does do an LDAP lookup which will either work or give you an error. Just use that step as the test.

Yes, the user exist in LDAP!

Look at an example from my AD and how is the configuration of Openfire, there is something wrong with this screen? suggests something?

http://www.netupload.org/visualizar.php?arquivo=i9ftwexl4yog9x2wj7ll.jpg

http://www.netupload.org/visualizar.php?arquivo=ckkxirv2bs3e6x0czhzx.jpg

Just suggestion:

  1. try to use other ldap browser, for example, jxplorer. if jxplorer can connect your AD by using your configuration of Openfire, then openfire can connect AD too.

  2. check your settings of user mapping about LDAP. Be sure that username field is the account which you want to use to login. if you set username field to “sn” and your account is “abc”, you must be sure that a user with sn=abc must exists in LDAP.

    1. while setting admin account, you must enter a valid value of username field. For example, your username field is “sn” and there is an user with sn=abc, then you can enter abc to set this user as an administrator. if you want to set an user with sn=abc@def.com as an administrator, you must enter abc\40def.com

if all these settings are right, i have no idea to help you.

wish it will help you.