powered by Jive Software

Problem in installing WildFire

respected friends,

iam new here…

right now iam just creating an IM tool… for instant messaging…

and i have downloaded WILDFIRE server for the Messaging purpose…

during the ADMIN CONSOLE setup…i have selected the embedded db and it works fine…

but i need to connect to my SQL SERVER db residing in the server machine…

when i tried to connect…it throws out an error and i couldnt able to proceed…

ur help is highly appreciated…please help me

regards

Vathan

Vathan

Please let us know regular necessary information like error, info, warn, debug log and your configuration. When you post them, it is always useful to put these things in a tag.

Here is the example:

error warn info debug log and configuration

/code

to display like this you need to try things like this

error warn info debug log and configuration

Regards,

wmhtet

You mean you first used the embedded db and now you are trying to install the server again and you want to use your SQL Server, is that true? What is the error message you are seeing?

2006.03.10 11:06:58 [org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnecti onManager.java:369)

]

java.lang.NullPointerException

at org.jivesoftware.database.DbConnectionManager.setMetaData(DbConnectionManager.j ava:533)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:356)

at org.jivesoftware.wildfire.admin.setup.setup_002ddatasource_002dstandard_jsp._js pService(setup_002ddatasource_002dstandard_jsp.java:194)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:98)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

2006.03.10 11:06:58 [org.jivesoftware.database.DefaultConnectionProvider.getConnection(DefaultConne ctionProvider.java:68)

] Warning: DbConnectionDefaultPool.getConnection() was called before the internal pool has been initialized.

2006.03.10 11:06:58 [org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManage r.java:116)

] WARNING: ConnectionManager.getConnection() failed to obtain a connection.

this is the error recorded in the error log file

thanks for ur interest

regards

Vathan

vathan

Are you familiar with the SQL server? Cause I am not. Today, I have been struggling with my mysql server for my testing wildfire server(it works now though). Anyway, it seems that there is a problem connecting to your SQL server, can you make sure if your SQL server is running properly? Can you also post your wildfire configuration file?

Regards,

wmhtet

My SQL SERVER is running properly…

iam online in GMAIL…

my id is vathanasegaran@gmail.com

i would be very happy if u buzz me up and help me

and here is the CONFIG FILE…

<?xml version="1.0" encoding="UTF-8"?>

regards

vathan

vathan

It seems that you have read the thread how to get answer fast but too bad, you should have waited a bit longer and read the link that Ryan has posted.Addressing people ‘‘sir’’ is polite of you and giving points to our post show you have read the ‘‘how to’’ thread. It is also clear that you have searched the forum because of all the replies. However I don’‘t think you have read all the SQL threads that you replied because you just keep on asking if they were solved. You can see that most of them were marked as Answered (solved). I don’'t think that people here will be happy about such postings. I once were in your shoe too (not exactly the same though). I had difficulties with MySQL. I post the question here and Matt said that it was a bit outside the scope of this forum.

http://www.jivesoftware.org/community/thread.jspa?threadID=15418&tstart=0

Well, I can’‘t do anything about that. I can only thanks jivesoftware for providing the software and providing the help they can. I just can’'t ask them more. It also showed that I need to do my own homework. I have solved the issue outside the forum using a wonderful tool called ‘‘google’’. I want to help you but I am not very good with SQL myself. I have asked you to provide config and logs so that if someone with the right knowledge came along, that person might answer it for you. I believe that you might be able to solve the problem yourself also because you are the one who has the hands on your server physically and you are the one who knows the config and the enviroment better. But you might need to do some homework though. .

peace

wmhtet

Hey vathan,

I guess that there are more exceptions before the one you posted. Can you post them so we can see the original connection problem?

Thanks,

– Gato

Respected Sir

i have downloaded the WILDFIRE SERVER for instant messaging from JIVE SOFTWARE.ORG

i have installed the server and made it to run…

i tried to configure the admin console…

while configuring the db settings…i tried with embedded sql…and it was working fine…but i want to connect the wild fire server with the sql server db present in my intranet…

so i just downloaded the sql server 2005 jdbc driver and placed the files in the lib directory of the wild fire…

and specified the driver class URL as com.microsoft.sqlserver.jdbc.sqldriverclass

and i tried to connect with my local db with database url :jdbc:sqlserver://backup:1433;databasename=wildfire;appName=jive

the following error occurs

Failed to establish a database connection - please see specific errors listed below.

Unable to load the specified JDBC driver. Please verify the name of the driver is correct and that the driver is in the classpath of this server (usually the ‘‘lib’’ directory). If you add a driver to your classpath you will neeed to restart the server.