powered by Jive Software

Problem installing wildfire_3_2_3.rpm

Dear Guys,

i have downloaded and tried installing wildfire_3_2_3.rpm with rpm -ivh wildfire_3_2_3.rpm

Installation was successfull but if i want to start the Wildfire Server by ./wildfire start

i get the Error-Message that the JRE must be at least Version 5. So i thought the RPM has the JRE included?

What to do?

Greetings,

sunny

Actually, I have a list of issues with that RPM here too.

  1. the RPM still doesn’'t respect existing custom files like wildfire.xml, keystore, and truststore.

  2. the wildfire binary doesn’‘t play well with FC6 for some odd reason and complains about the wildfireHome variable not being set. This requires a change of the /opt/wildfire/bin/wildfire file to change $app_home to /opt/wildifre. More testing with the Redhat/Fedora environment to determine why the $app_home variable isn’'t being set right would be suggested.

  3. The Redhat start stcript installed by the redhat-postinstall.sh extra, calls the startup file wildfire.sh. This causes problems with non-existant file complaints when one tries to start the service after install.

A clean RPM shouldn’‘t require THIS much tweaking after the fact. I mean, I can see needing to run the database upgrade scripts before starting the new service after a MAJOR upgrade like from 3.1.0 to 3.2.3, but this kind of destruction, like overwriting the wildfire.xml or clobbering the certs in the keystore just isn’'t fair.

I believe the clobbering point was made previously (circa 3.1.0) but I don’'t know if anyone has noticed the wildfired typo yet.

Any chance these things could get some attention in future wildfire/openfire releases so that those of us using the RPM’'s for speedy deploy can do so without excessive backups and tweaking?