powered by Jive Software

Problem logging in after update

I have a installation of Openfire installed and it has been working for some time now. However, I had been putting off the upgrade to the newest version and now am updated to version 3.7.1. Everythign seemed to go smothly until I tried to log on as admin. Actually none of the admin users can log in. However, They can still log in using spark just not the web gui. I have tried changing the “newinstall” to reset the administrator password and it did not work. What is the next step. I need to add users and double check to makes sure everything else is running smothly. Like I said Spark has had no problems at all. THank you for any repsonce in advance. You guys have always been good at finding a way to help me before.

I suppose you are not using LDAP integration, or do you? If os, then maybe you have changed administrator’s password in AD recently.

You can try rerunning the setup. Stop the Openfire, edit /conf/openfire.xml and change tag value to false. Then run Openfire again and go through the web setup process again using same settings.

I am using the local db option and have tried running the setup process but to no avail. I have changed the password there and it still does not let me log in. Spark still works fine but no administration/webgui can log in. The passwords for the spark works fine for users who have administrator privilages but they cannot log in to the gui. I have changed the Aministrator password as you have pointed out above and still I cannot log in. Is it possible that a service is not running properly or the database is corrupted? Just throwing out options. Thanks for the quick response

Don’t know what can it be. You can try uncommenting authorizedUsernames tag in the openfire.xml and adding same admins usernames or maybe other usernames and try to login with them.

Gave up and unistalled then reinstalled. Had to rebuild from scratch but that’s ok Only had 10 users. It was the config I was trying to save. All the Astrisk-IM and FastPath and such. Oh well, at least it is back up now.