Problem unjarring plugins on Mac OS X

I’'m using Eclipse 3.2 to develop a plugin for Spark. I successfully compile and build the jars for the plugin using the ant scripts on Windows. Spark and my plugin start and run fine under Windows. When I took my build over to a Mac running OS X 10.4 and tried to run, I received the following: error in opening zip file

at Method)


at org.jivesoftware.spark.PluginManager.unzipPlugin(

at org.jivesoftware.spark.PluginManager.expandNewPlugins(

at org.jivesoftware.spark.PluginManager.loadPublicPlugins(

at org.jivesoftware.spark.PluginManager.loadPlugins(

Furthermore, all of the .jar files in the plugin folder now have 0 kb size.

I tried building on the Mac, but got the same results.

Can anyone shed light on what’'s happening, why, and how to fix it?


  • Jasen.

Strange. I haven’'t tried any of my Spark plugins on the Mac, but I have copied many jar files that were built on Windows to the Mac with no issues.

Have you tried to manually unjar the file on the Mac to see what is in it? Either do jar -tf <jarname> to list the contents or jar -xf <jarname> to extract them.

Running “jar” as in your example works fine.

  • Jasen.