powered by Jive Software

Problem with compiling videoConf.lzx to videoConf.lzx.swf

Hi, Dele!
Can You help me with the plugin red5.war?
I want to change video res:160х120 to 320x240 in conference ‘12 person’.

But first I tried just to compile original videoconf.lzx to swf.
I used Windows XP SP2, Java EE SDK 5.0 Update 1, OpenLaszlo 3.4,

command С:\OLS34\lzc.bat videoConf.lzx
I got videoConf.swf (78796 bytes) renamed to videoConf.lzx.swf and replaced original file (78740 bytes) with it.
I assembled plugin by command C:\sun\sdk\jdk\bin\jar cvf red5.war .
I reinstalled plugin on server.
I chose any link in part “12 person audio/video conference”, then opened empty white page with yellow inscriptions (test1 test2 test3 audio: on video:on) and no video. Why?

Test it from 3 browsers

  1. http://your_server:7070/red5/video/videoConf.html?me=test1&others=test1|test2|te st3

  2. http://your_server:7070/red5/video/videoConf.html?me=test2&others=test1|test2|te st3

  3. http://your_server:7070/red5/video/videoConf.html?me=test3&others=test1|test2|te st3

I tried conference in Opera 9.64 (with Flash 9 and Flash 10) or Internet Explorer (with Flash 9) between two computers. No video.

Screenshot and my compiled videoConf.lzx.swf are in attach.

Video is available with original videoConf.lzx.swf. My videoConf.lzx.swf have another size than original videoConf.lzx.swf. Is any problem with compiling?


videoConf.lzx.swf (78740 Bytes)

Sorry, not in a postion to test your swf file. Post the lzx source code here and I will take a look at it.