powered by Jive Software

Problem with conference rooms

Hello

I use internal database, updated to beta 2 today and now i have following problems:

When i try to join a conf.room i get “error 404 not found”.

When i delete the room from the list and try to reinstall it in admin-webinterface, it says: room with the id is always there, even there is nothing shown in webinterface.

When i install it via jabber-client same problems.

The following message i get when editing the room in that admin-webinterface:

Fehler:

org.jivesoftware.messenger.muc.ConflictException at org.jivesoftware.messenger.muc.spi.IQOwnerHandler.processConfigurationForm(IQOw nerHandler.java:359)

at org.jivesoftware.messenger.muc.spi.IQOwnerHandler.handleDataFormElement(IQOwner Handler.java:309)

at org.jivesoftware.messenger.muc.spi.IQOwnerHandler.handleIQ(IQOwnerHandler.java: 87)

at org.jivesoftware.messenger.admin.muc_002droom_002dedit_002dform_jsp._jspService (muc_002droom_002dedit_002dform_jsp.java:289)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:78)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

The old userdata are accepted withou any problem.

Maybe i did something wrong in that update.

Is anyone able to help me?

regards

Jonathan Yih

Message was edited by:

Jonathan Yih

try reading this:

http://www.jivesoftware.org/forums/thread.jspa?threadID=15131

http://www.jivesoftware.org/forums/thread.jspa?threadID=15061

you have to make some changes to DB manually if upgrading with nightly builds nad last betas and not directly 2.1.5 > 2.2.0 beta x

It worked for me, but if it’'s not hard, i will suggest to delete and recreate DB again.

Thx for your reply.

What about user import and export plugin?

Is the following maybe a way for me?

save all users, get a new db, and import all users again?

(btw: were to get or how to create the new db??)

regards

hm… interesting, may work. But you should ask Ryan (maybe PM him) if his plugin will do that trick. Internal DB is creating automaticly. SO to recreate it, just stop server, delete embedded-db folder and run server again. ANyway, you can always backup your DB folder and then try to play with ImportExport plugin. If something goes wrong you can restore old db.

As far as i can see it worked for me with user-import/export plugin.

Thx wroot and thx who ever wrote this plugin.

best regards

it’'s a Ryan, a plugin guy

http://www.jivesoftware.org/forums/profile.jspa?userID=4739

Well i lost 1 user-group, but not a single user nor a single password or something else. So not a big deal to repair everything.

I am very happy it works perfect now.

big THX to you guys

regards

Hi Jonathan,

I am glad to hear the plugin worked for you. I am curious to find out why a group went missing during the import; if there is a bug I would like to squish it. Did you see any sort of message in any of the logs after you did an import about the plugin not being able to create a group?

Thanks,

Ryan