powered by Jive Software

Problem with moving Wildfire to new server

Hi All,

In the fortunate position of being able to bring up a new VM to host a new Wildfire instance, but I’'m running into problems.

Virtual servers both Ubuntu 6.10, old Wildfire is 2.6.2 new one is 3.2.4.

I thought (hoped) I could just drop the new service, copy over the wildfire.xml file and the embedded-db folder, and bring the service back up, but it restarts setup like a brand new install, then fails at the opening database step with the following error (from error.log):

2007.04.03 10:39:16 org.jivesoftware.database.EmbeddedConnectionProvider.getConnection(EmbeddedConne ctionProvider.java:46) Error: EmbeddedConnectionProvider.getConnection() wascalled before the internal pool has been initialized.

2007.04.03 10:39:16 org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManager. java:95) WARNING: ConnectionManager.getConnection() failed to obtain a connection.

Any ideas? Is this just a dumb way to transfer it? I should explain that it’‘s a simple private setup, few users and rooms and the new server will be taking over the DNS alias from the old server once I’'m happy its working, so as to provide a seamless transfer - just want to do it right in case I need to do something similar with a bigger implementation.

Thanks in advance!


I wonder if you did set the right permissions. As 3.2.4 uses still “wildfire” and not “openfire” it should work fine as you did try.

You could try to start Wildfire 324 without the embedded-db folder and let Wildfire create it, stop Wildfire and overwrite the files with the one of your current production server. You can usually copy all files on-the-fly without the need to shutdown your production server.


Many thanks, and apologies for being a moron - I’‘d copied the old settings to a PC via SCP sometime ago, then uploaded them to the new server - the embedded-db folder and wildfire.xml were owned by root - chowned it all back to jive:jive and it’‘s looking good. One day I’‘ll learn to check permissions FIRST, but don’'t hold your breath…