powered by Jive Software

Problem with Openfire 4.6.4

since upgrade to 4.6.4 conversations clients cannot connect any longer
after a short while they show status “invalid session/connection” in admin webinterface current sessions
downgrading to 4.6.3 solved the problem

Hello,
I forgot to mention that I also tried with 4.7.0 nightly
same problem
with 4.6.3 clients are now stable connected since more than 12 hours

to reproduce upgrade to 4.6.4 and try to connect with conversation android client (can be installed / downloaded from f-droid)

Hello!
we got absolutely same problem with openfire 4.6.4. we tested conversations, gajim,xabber. all clients disconnected and in admin-UI got invalid session/connection.

downgrading to 4.6.3 solves problem for us too

Hello,
I am relieved that I am not the only one facing this problem.

Hello,

same problem, 4.6.3 all ok, 4.6.4 “invalid session/connection” after some time.

Thanks for reporting this. This is of concern, as we’ve not heard anything about this before. On first glance, I can’t identify a change that would be likely to cause such an issue.

Can you please provide more detailed information? Does this affect all sessions? What is the timing of events? Is there anything of interest in the log files?

Hello guus
unfortunatelly this affects all Sessions.
After Server reboot all clients are connected for maybe one min or less
after that I still see them listed in session view but all with the same error “invalid session/connection”
from client side the connection is interrupted and client tries to reconnect

Please review openfire’s logs for any clues.

Hello,
I reviewed my log history when 4.6.4 was running but coundn’t find anything helpfull.
Maybe a debug log would be helpfull but as I am running 4.6.3 now, I can’t provide this at the moment.
Perhaps anybody else with this problem is able to provide such log.

It would be nice to give some details about the network you are using…
Router, Firewalls, etc…
I have this issue too (on 4.5.x and prior too) and sometimes it has sth. to do if one of the firewalls was rebooted by an admin, so the tcp connection get corrupted…
But on my net it only happens once or twice a week.
@cybero2912 and @dukk: Do you have a simple network or a more complex one?
Is OF running on Linux or Windows Server? Which Java Version are you using?
The more infos we get, the better we will be able to analyze the problem. Are you able to reproduce the issue on a seperate test server too?

OF server was running on RHEL 7 24x7. 2 CPU cores, 2Gb of RAM.
Again: It was running without issues with 4.6.3 version. but fail after update.
Clients slightly vary its nework capabilities: cellular 3G/4G, wifi, Optical Ethernet, Wire Ethernet.
It was NOT router or other issue clearly. see other people reports! After downgrading - all is fine.

Clients will be disconnected by server after random amount of time. sometime it’s few minutes (5-10) sometime its hours before disconnect.
After got “invalid session/connection” i go to server console → forcefully drop this connection and after minute THIS client can normally connects once again.
Restarting OF service fix problem too.
We are using bundled JAVA version (installed from official OF RPM published by igniterealtime).

If i lauch network sniffer to capture session, i see TLS handshake (client server hello messages) and after that client forever waith for server to respond and server is NOT responding to client.
Normally (then OF working) after a TLS handshake, server start pushing application data stream to client.

I can’t upgrade to 4.6.4 again to grab logs, because userbase will not be happy with problems raising again…

Here Openfire is running on latest Debian 10 (Buster)
Java 11 from official repo

Would be nice if you could test 4.6.4 without using TLS (plain only) to see if the issue comes from that part of code (may be thread deadlock somewhere)…