powered by Jive Software

Problem with Openfire 4.6.4

One more question @guus : what does the following warning stands for?

[socket_c2s-thread-2]: org.jivesoftware.openfire.nio.ConnectionHandler - Closing connection due to exception in session: (0x0000F4E3: nio socket, server, /172.254.1.38:63221 => /172.31.22.80:5222)
java.io.IOException: Closing session that seems to be stalled. Preventing OOM

This warning is flooding my logs :confused:

That message occurs when Openfire has queued up to a configurable limit (5MB by default) of data to be read by a client, without the client reading that data. If that happens a lot, then it suggests that clients connections disappear from Openfire, without Openfire realizing it (until this limit kicks in, that is).

ok, so this could be a sympthome for the origin invalid session problem too :thinking:

update: that points me to the xmpp ping… if i would decrease the ping time, then openfire should notice such dead connections ealier

1 Like

btw. i have noticed that i am not able to force close “invalid session/connection” or “detached” connections on the admin console “sessions-summary.jsp” tab

furthermore i have noticed that OF will close detached session itself but invalid session will stay although this session is marked as offline and status is closed

@guus : i hope this wont result in a memory leak…

Na versão 4.6.4 o plugins de monitoramento de conversar está instalado porém, não aparece na barra principal.

I have debugged around and found out that if the (mina) Connection object in LocalSession is somehow corrupted (network errors or other …) a
sess.getHostAddress() in session-row.jspf
will fail and results in
Invalid session/connection

A click on “Close connection” on admin console (session-summary.jsp) allways fails on detached or invalid session because the call of sess.close(); (in session-summary.jsp) fails. It should call the close method of the Session object, but if this is corrupt or null it wont call the closing event with further clean up tasks, so the session wont be deleted. The problem is that new sessions will not be correctly initialized then too but i dont now exactly why.

I found a thread on stackoverflow with a good explanation which might be a reason for this issue (the post which was marked as solution) java - Apache Mina, How to detect when you're sending messages using an invalid socket to the client side? - Stack Overflow

Hi guys, I have the same problem in my Open Fire server version 4.6.4.
Any solution or idea to solve this problem?

Hopefully this will be fixed within the next version
until then I am using 4.6.3 without any problems :wink:

I had an issue with 4.6.4 as well in our environment. The XMPP service on 5222 just stops accepting new connections. Existing connections continue functioning properly. The port stays open and you can connect to it, but the server never responds. Rolling back to 4.6.3 also fixed our issue.

I am only able to reproduce the issue in our production environment, the dev environment has been stable on 4.6.4, but it also does not receive near the amount of traffic the prod systems do.

Has anyone updated to Openfire 4.6.5?)

I’m waiting for the same answer.

Hello,
I’ve updated to 4.6.5 one hour ago
until now everything seems to be fine - all clients connected (conversations client version is 2.10.2+fcr)

1 Like

24 hours later still no problem with client connections

from my side nothing was changed in the configuration
seems the problem is solved in 4.6.5 :+1:t2:

1 Like

Nice to hear this. Seems today I will be updating my Openfire)

In my case the problem persist.

@RuiSimoes as this thread is set to solved by me and I am not able to reopen it for you, you should open and new one including openfire logfiles as attachments

There were no commits related to connection since OF 4.6.2 i think so the issue should be still there

What can I say ?
no problem so far :slightly_smiling_face:

Open new ticket

I have similar problem in 4.6.6

https://discourse.igniterealtime.org/t/problems-after-upgrade-to-4-6-6/