Problem with Openfire connection to postgresql

I have Openfire 3.9.3 running on a RHEL6 installation. When I enter the FQDN in search domain in network settings on the VM Openfire is running on Openfire can no longer connect to Postgresql and the service stops running. If you check the logs, Openfire failed to connect after eleven tries. The Postgresql logs have no indication that a connection was tried and failed. If I remove the FQDN and reboot the VM everything works correctly. All parts reside on the same VM and it used to work. Has anyone seen this before?

Elrond Wojtkiewicz

When you say ‘remove the FQDN’, does that mean you revert to using an IP address? Perhaps it is reverting to use localhost/socket? Are you able to connect via the command line using the FQDN?

psql -h FQDN openfiredb

I am talking about putting the fqdn in the search domain under the network settings (edit connection) in Red Hat. If I leave that blank openfire connects to the database without a problem, with the fqdn entered it will not connect.

The search domain would not be the full FQDN, but only the trailing portions. For example, if your hostname was, your search domain would be Then in openfire, you could specify a hostname of ‘abc’