Problem with Testing Openfire with Grinder (BOSH load testing)

I have been trying to test openfire server for Load testing over BOSH but I have been getting the following error after few minutes of run.

11/4/11 3:49:33 PM (thread 3 run 0 test 601): Aborted run due to Java exception calling TestRunner

Java exception calling TestRunner

File “D:\grinder\projects\loadtest\bin…\tests…\tests\”, line 144, in changePresence

File “D:\grinder\projects\loadtest\bin…\tests…\tests\”, line 208, in call

Caused by: Address already in use: connect

  1. I have also been getting 404 Invalid SID errors.

Initially I had set up openfire on Windows 2003 Server but later I set it up on ubuntu 11.10 (RAM 2.0 GiB Intel Core Duo T2400 @ 1.83GHz)

  1. Firstly, I ran php curl fetch script to add users to using the userservices plugin to add something around 10,000 uses (during which I got a lot of blank responses , so may be this is related to the problem but I will not focus on this misbehaviour now)

  2. But I needed to test this for 400 users so i had the following set:










(this strangly ended up starting only 103 concurrent users)

(I have tried testing this using one agent)

  1. I did a bit of a research and found that I could configure openfire for bosh; so i added the following

xmpp.httpbind.client.idle 360

xmpp.httpbind.client.requests.max 400

badly need help!!! anyone has an insight about how can i resolve this?