powered by Jive Software

Problem with wildfirehome

Dear all,

I am newbie here, i have problem with wildfire setup. I am using ubuntu 6 and when i’'m trying to setup through firefox, i got this message “Home not found. Define system property “wildfireHome” or create and add the wildfire_ini.xml file to the classpath”.

I already search about this topic, but i haven’'t solve the problem. Can you explain how to solve this one ? Sorry if i am bothering you all with this one, cause i know this thread already exist. Thank You.

Regards,

Johan

Hi Johan,

I expect that you have a problem with the start script. You may try the script provided here http://wiki.igniterealtime.org/display/WILDFIRE/LinuxInstallationGuide#LinuxInstallationGuide-WildfireStartScript to start Openfire. Adjust the Openfire and the Java path to match your needs.

LG

Dear LG,

Which one should i do ? Wildfire Installation, Update or Start Script ?

All I need to know is how to define system property

Hi,

you may just try the three lines start script.

LG

I Still Don’'t understand

You said that i have to run this following script, right ?

#!/bin/sh

cd /home/jivewf/WF/bin

nohup /opt/java/jdk1.5.0_08/jre/bin/java -server -Xms200m -Xmx500m -jar …/lib/startup.jar >…/logs/STDOUT.log 2>…/logs/STDERR.log &

But in my Ubuntu, there is no “jivewf” folder, my wildfire program stored in /opt/wildfire

what distro that you used to run wildfire ?

Hi Johan,

I wrote “Adjust the Openfire and the Java path to match your needs.” Should I also add modify the user, java parameter etc. to match your needs? It has nothing to do with the distribution you are using.

LG

Dear LG,

I already suceed install the server, I am using Mandriva 2006 as the server. I don’‘t know why Ubuntu didn’‘t working. Mandriva don’'t have problem at installation. Any way, thanks for the help.

Regards,

Johan

Assuming your running wildfire as user ‘‘jive’’, and its installed in /opt/wildfire try:

chown -R jive.jive /opt/wildfire

… during the install (if you’'re root when you install) all the files get owned by root.

I just upgraded to 3.2.4 and had the same problem. It turned out to be a bug in the rc script in the init.d directory looking for a file

/opt/wildfire/bin/wildfire.sh

apparently the file has been renamed to simply “wildfire” - no “.sh”