powered by Jive Software

Problema de autenticação

Boa tarde,

O meu ambiente é o seguinte Ubuntu 16, openfire 4.0.3, AD Windows Server 2012 e cliente spark 2.8. O openfire já está autenticado no AD, inclusive entro com meu usuário do AD no painel de administração do openfire, mais na hora de logar no cliente ele simplesmente rejeita o usuário e senha, retorna a mensagem de usuário e senha inválido.

Já limpei o cache do openfire e troquei a senha no AD, mais o erro persiste, alguém já passou por isso?

Bom dia amigo, pode ser alguma segurança do ubuntu 16, como se fosse o firewall do windows rejeitando login, porém eu subi a instalação aqui e deu certo o login, pode ser diferença de horário entre o AD e o servidor do ubuntu, dai ele da falha de login.

Este problema aconteceu comigo também, resolvi baixando a versão 2_8_0_887 e habilitando a opção Disable certificate hostname verification no menu Advanced no cliente spark.

Boa tarde Vinicius, eu já havia visto outros usuários relatando problemas com diferença de horário e foi o primeiro item que verifiquei, ambos os servidores estão sincronizados com o mesmo horário…

Boa tarde Erick, estou utilizando a versão 2_8_0_885, não localizei esta versão de final 887 que relatou, poderia disponibilizar o link? Tão pouco localizei a opção que mencionaste na guia avançado

@Wellington Pode baixar neste link: Ignite Realtime: Spark Nightly Builds
Tem até a versão 2_8_0_900.

Obrigado pelo link Fabiano, mais não funcionou, continua informando usuário e senha inválido.

Alguém poderia postar aqui todas as dependências para o pleno funcionamento do servidor openfire no Ubuntu? Estou começando a achar que faltou algo, subi um novo servidor hoje e continua com a mesma inconsistência, durante a configuração faço toda a integração com AD já retornando os grupos e os usuários mais na hora de autenticar no cliente não funciona.

Boa tarde, eu apenas instalei o java e pronto:

apt-get install default-jre

Aproveita e roda o apt-get update + apt-get upgrade

Se precisar, eu fiz o tutorial da instalação no ubuntu:

https://community.igniterealtime.org/docs/DOC-5273

https://community.igniterealtime.org/docs/DOC-5272

Um deles é com banco de dados interno, e o outro com banco de dados externo.

Não instalou mais nada Vinicius? Eu instalei o Apache, PHP e suas dependências e o java, não funcionou…todo o serviço rodando a principio perfeitamente, tudo autenticado e sincronizado, mais o cliente não conecta de jeito nenhum, sempre o mesmo erro de usuário e senha inválido.

Inclusive ao trocar a senha no AD, quando vou entrar na console de administração ele já solicita a senha atualizada.

Bom dia Wellington, instalei apenas o default lá, porém eu estou usando o spark antigo: spark_2_7_2

Boa tarde Wellington, descobri o problema, fiz a instalação do ubuntu 16 + ad + postgres, instalei o spark 2.8, também deu o erro de autenticação, ali aonde pede servidor no spark, eu estava colocando o IP do servidor do openfire, alterei em vez do ip, coloquei o hostname do linux, dai autentico.

Na versão velha do spark, 2.7.2, funcionava pelo IP, agora nessa 2.8, só funcionou pelo hostname.

Obs: Você precisa criar um apontamento host-a no DNS do AD, para poder resolver o hostname no ip do servidor do openfire.

Boa tarde Vinícius, acho que o cenário não poderia piorar mais, ontem por acaso eu descobri esse problema da versão do cliente spark a partir da 2.8 com o openfire 4.0.3. Eu já tinha um ambiente funcionando com o cliente 2.7.5 e a versão 3.10.2, então resolvi atualizar o openfire para a versão 4.0.3, fiz a atualização sem problemas e os usuários autenticaram normalmente, ai ao trocar uma estação de trabalho e instalar o novo cliente 2.8, deu o tal erro de autenticação, instalei a versão 2.7.5 e funcionou perfeitamente.

Agora olha o problema, eu subi o mesmo ambiente em outra empresa do grupo e era exatamente esse o meu problema, não conseguir autenticar, então com essa descoberta eu instalei a versão 2.7.5 e bingo, funcionou no mesma hora, mais quando fui fazer a conexão fora da rede interna deu o mesmo erro de autenticação e eu estou utilizando o cliente 2.7.5.

Sinceramente não sei mais o que fazer ou testar, acho que esgotei minhas possibilidades. Na rede interna funciona, numa conexão qualquer de internet recusa o usuário e senha, estou usando o mesmo para ambas conexões.

Quanto a conexão do servidor eu sempre fiz por hostname, nunca por endereço IP, pois isso facilita na manutenção. Eu posso simplesmente subir um servidor em paralelo com outro endereço IP e criar uma entrada DNS para ele, sem haver a necessidade de trocar a configuração no cliente.

Bom dia Wellington, dai nessa conexão externa você esta usando um apontamento dns para resolver o ip externo ou instalou a versão antiga do spark para conectar direto pelo ip?

Eu tentaria a versão bem antiga do spark, segue links:

2.7.2: spark_2_7_2.exe - Google Drive

2.6.3: spark_2_6_3.exe - Google Drive

Verifica no arquivo de log, lá que eu vi que ele retornava o erro por causa do hostname.

Boa tarde Vinicius, estou usando um apontamento DNS para resolver o ip externo, mais também tentei a conexão diretamente pelo ip externo e não funcionou. O mais estranho é que possuo um ambiente quase idêntico, onde tudo está funcionando, inclusive a conexão externa.

A diferença é que no ambiente que está funcionando o openfire foi atualizado para a versão 4.0.3 e no outro ambiente foi feita a instalação do zero, estou utilizando banco mysql e openfire 4.0.3 em ambos

Bom dia Pessoal, o meu problema foi resolvido utilizando o cliente spark 2.7.5, com o cliente 2.8.x realmente não funcionou. Outra questão que influenciou na resolução do problema foi a substituição do firewall da empresa que era administrado por terceiros, após implantação de solução interna tudo funcionou perfeitamente, agradeço a atenção de todos.