powered by Jive Software

Problemas OpenFire

Na empresa em que eu trabalho, utilizamos o OpenFire juntamente com o Spark. Utilizamos também, um plugin do OpenFire chamado “Kraken IM Gateway” que possibilita aos usuários fazer o login com o usuário do MSN Messenger.
Porém, estamos enfrentando alguns problemas com esta aplicação, gostaria de saber se alguém conhece estes problemas, e uma possível solução para eles.

  1. Alguns usuários cadastrados no Open Fire quando fazem o login no Spark, apesar de conseguir interagir com todos os usuários, o mesmo aparece offline para todos.
  2. Quando o usuário tenta interagir com outro usuário que utiliza o MSN, algumas vezes aparece offline para algumas pessoas e online para outras.
  3. Algumas vezes, quando é enviada uma mensagem para um usuário do MSN, ele demora cerca de 5 minutos para receber esta mensagem, e alguns casos, nem a recebe.
  4. A aplicação do OpenFire cai com frequência.

Alguém sabe como resolver estes problemas???

Obrigado.

Vamo lá…vou tentar te ajudar,

1) Alguns usuários cadastrados no Open Fire quando fazem o login no Spark, apesar de conseguir interagir com todos os usuários, o mesmo aparece offline para todos.

Re: Cara, se tu loga e consegue ver “todo mundo”, mas “todo mundo” não te vê, pode ser a aplicação da permissão reversa, ou seja, você diz pro openfire que o grupo onde você está vê um determinado grupo X, mas não disse pra ele que o grupo X tem que ver o grupo ao qual você faz parte. Pode ser que seja isso, tenho quase certeza que o openfire não entende as permissões como via de mão dupla…tem que setar dos dois lados…se não me engano tive problemas com isso aqui na empresa no início, tanto que até criamos aqui uma ferramenta para fazer exatamente isso.

2) Quando o usuário tenta interagir com outro usuário que utiliza o MSN, algumas vezes aparece offline para algumas pessoas e online para outras.



***3) Algumas vezes, quando é enviada uma mensagem para um usuário do MSN, ele demora cerca de 5 minutos para receber esta mensagem, e alguns casos, nem a recebe.


Re: Tá com cara de ser pau no plugin. Não vejo sentido o spark causar isso. Eu já tive esse problema da pergunta 3. Vira e mexe tem um retardo gigante pra receber mensagem, quando recebe. Igual falei, acho que é pau no plugin.

4) A aplicação do OpenFire cai com frequência.

Re: Cara, podem ser N coisas. Tenta detalhar o que realmente acontece.

Espero ter dado uma clareada ou pelo menos ter aberto portas para a solução.

Té.

Bom dia,

Obrigado pelas respostas.

Uma pergunta, que plugin voce usa para fazer a integração com o msn???

Obrigado.

Pedro Henrique Piccelli

mailto:ppiccelli@brastel.com.br ppiccelli@brastel.com.br

DEV - Londrina - Brazil

De: vcosta communityadmin@igniterealtime.org

Enviada: quarta-feira, 4 de agosto de 2010 11:12

Para: pedro.piccelli

Assunto: - Re: Problemas OpenFire

http://community.igniterealtime.org/index.jspa Ignite Realtime

Re: Problemas OpenFire

created by vcosta http://community.igniterealtime.org/people/martinelli03 in Brasil - View the http://community.igniterealtime.org/message/205344#205344 full discussion

Kraken IM Gateway

quase 2 anos após o problema se repete…heheheh

acabei de instalar o openfire, 3.7.1, coloquei o kraken 1.13.2 e consigo ver todos os usuários do msn, porém recebo as mensagens, e não consigo enviar, ele não apresenta erro algum, somente não envia.

alguem pode dar uma luz?

Estou com um problema parecido, utilizo o OpenFire 3.7.1 e testei todos os plugins do Kraken a partir do 1.1.2, porém, não consigo fechar a conexão entre o clinte (Spark) e o MSN, sempre dá uma erro de senha (mesmo digitando corretamente e quando mudo o plugin dá uma erro de conexão, agluém poderia me ajudar?

Só pra deixar registrado, referente ao meu problema, havia instalado o openfire em um servidor Windows, apresentou diversas incompatibilidades, principalmente com os plugins (Kraken), desisti e instalei o Openfire em um servidor Linux Debian, está funcionando quase que perfeitamente, estou tendo apenas problema com 1 usuário no qual ele insiste em quando o mesmo se loga consegue se comunicar com outras pessoas pelo msn, mas passa um tempo essa comunicação cai, os dois lados aparecem online mas a troca de mensagens não é feita, estou estudando o caso e assim que tiver uma resposta reporto aqui.

Bom amigo, eu passei dois dias pra descobrir esse misterio… Na minha seituação foi o seguinte: Fiz o servidor e estava instalando o spark nas estações, tiveram uns 2 usuarios que entrava no spark mais ninguem conseguia visualizar ele online… eu, devido a esse problema andei mechendo em algumas configuraçõesdo do usuario e acabei mechendo na “aba” MEMBRO DE: e aacabei mechendo no grupo padrao ou seja, eu alterei o grupo padrao… e descobri que se mecher no grupo padrao dá problema. Entao eu exclui esses dois usuarios, criei novamente e apertei stop e start, feito isso os usuarios apareceram como online.