Problems Connecting on Database Settings on Openfire Setup

Have database made called “OPENFIRE” when creating database connection in Openfire Setup I can on get it to connect.

Steps I have taken:

  1. Added port in Firewall 1433

  2. Created “OPENFIRE” Database and tried w/o a Database created or designation

  3. added server(computers) IP address to Host file

  4. Added Port to Server Configuration on TCP/IP

  5. tried host name and server name all under these different ways:






  1. VIA and PIPES are disabled

  2. TCP/IP is enabled

  3. Dynamic Port is “0”

  4. Made sure my Database is set for “SQL Server and Windows Authentication mode”

any other suggestions

I am new to using using and creating databases but my goal is to get Spark working thus I am still learning.


Did you use SA or create a new user for openfire?

I can tell you for sure the correct jdbc string is:

jdbc:jtds:sqlserver://localhost/openfire;appName=jive (In my case I’m running thedb on the same server)

When I had that issue, it was user permissions on the database. When I tried SA it worked. Then I just kept tweaking the user account ‘ofa’ that I made (Open Fire Admin) until it was passing connection.


I tried that but still no go. I am not sure what I am doing wrong on the SQL Server to for it not connect.

Does anyone know any settings on SQL so that I can get this to work. Much would be appreciated.