powered by Jive Software

Problems logging on to openfire

Hello everyone:

Well from what I see there is a semi common trend some people have problems login on to their account after creation. And I myself am not exempt from it…

I have tried several times to get this right and I have not been able to get in everytime.

I have uninstalled and reinstalled, I have edited the xml setup to false and restarted… I have restarted the server after setup, everything I have done doesn’t work.

The user name I’m using is admin, and then my password… I have checked all of this multiple times and can’t figure out what I’m doing wrong. I have tried upper and lower case Admin, and played withmy password, with out joy.

I also looked in the beginning at the XML file and the username and password were my normal ones that I use, but they didn’t work. I’m all out of ideas.

I’m trying to get a dedicated Chat applet on my helpdesk portal for my customers and I’m stuck…

also this is an “error” that i’m getting in my admin portal:

Openfire 3.6.4 [Mar 28, 2010 12:32:48 AM]

Admin console listening at:

http://127.0.0.1:9090

https://127.0.0.1:9091

java.lang.IllegalArgumentException: Illegal JID: http://mywebsite.org

at org.xmpp.packet.JID.init(JID.java:396)

at org.xmpp.packet.JID.(JID.java:231)

at org.jivesoftware.openfire.SessionManager.initialize(SessionManager.java:1239)

at org.jivesoftware.openfire.XMPPServer.initModules(XMPPServer.java:544)

at org.jivesoftware.openfire.XMPPServer.access$400(XMPPServer.java:97)

at org.jivesoftware.openfire.XMPPServer$1.run(XMPPServer.java:391)

Caused by: org.jivesoftware.stringprep.IDNAException: Contains non-LDH characters.

at org.jivesoftware.stringprep.IDNA.toASCII(IDNA.java:106)

at org.jivesoftware.stringprep.IDNA.toASCII(IDNA.java:53)

at org.xmpp.packet.JID.init(JID.java:367)

… 5 more

java.util.ConcurrentModificationException

at java.util.LinkedHashMap$LinkedHashIterator.nextEntry(Unknown Source)

at java.util.LinkedHashMap$ValueIterator.next(Unknown Source)

at org.jivesoftware.openfire.XMPPServer.initModules(XMPPServer.java:541)

at org.jivesoftware.openfire.XMPPServer.access$400(XMPPServer.java:97)

at org.jivesoftware.openfire.XMPPServer$1.run(XMPPServer.java:391)

Exception in thread “Thread-10” java.lang.NullPointerException

at org.jivesoftware.openfire.handler.IQOfflineMessagesHandler.stop(IQOfflineMessag esHandler.java:192)

at org.jivesoftware.openfire.XMPPServer.shutdownServer(XMPPServer.java:899)

at org.jivesoftware.openfire.XMPPServer.access$600(XMPPServer.java:97)

at org.jivesoftware.openfire.XMPPServer$1.run(XMPPServer.java:398)

This is my first time setting up all of this stuff. I have always just worked with the computer itself, not setting up servers and such.

I look forward to any replies thank you have a great day

Cbarnard

Hi,

I assume that Spark or any other client do work fine and that only the applet hat this problem. Is there a place where you did specify “http://mywebsite.org” in your applet? There you should specify "user@mywebsite.org" to solve the “Illegal JID: http://mywebsite.org” error.

LG