powered by Jive Software

Problems logging onto Admin Console

If anyone can help…I would be most apprecitative…

I am having problems logging onto my Admin Console…

It was working before…however now it is not…not sure exactly what has changed…

running Wildfire, Version: 2.6.2 on Fedore Core 4 system:

uname -a

Linux snowboarder.topica.com 2.6.15-1.1833_FC4 #1 Wed Mar 1 23:41:37 EST 2006 i686 i686 i386 GNU/Linux

ERROR:

Login failed: make sure your username and password are correct and that you’'re an admin or moderator.

From the local host I can connect via command line:

telnet localhost 9090

Trying 127.0.0.1…

Connected to localhost.localdomain (127.0.0.1).

Escape character is ‘’^]’’.

^]

Frome a remote host I can connect as well:

$ telnet snowboarder 9090

Trying 192.168.129.175…

Connected to snowboarder.

Escape character is ‘’^]’’.

^]

Netstat shows server is listening:

netstat -an | grep 9090

tcp 0 0 :::9090 :::* LISTEN

netstat -an | grep 9091

tcp 0 0 :::9091 :::* LISTEN

IPtables is stopped:

/sbin/service iptables status

Firewall is stopped.

I had a problem when I first installed connecting to the Admin Console…I had to disable SELinux…and this enabled me to access the Admin Console…

Now I am unable to authenticate…username and password have been verified…

Looked through this forum and checked all possible fixes…but still to no avail…

Anyone know what else I can do…?

Thanks,

John Dworske

John,

Are you using LDAP or the database to store user accounts? One place to check first would be the error log (in the logs directory). You might see some messages there that will give you a better clue as to what’'s going on. Otherwise, you might try resetting the admin password in case it changed somehow?

Regards,

Matt

Matt,

Thanks for the reply…I am using MYSQL database…it was working before…now it is not…

The logs are not showing me much information regarding accessing the Admin Console…

logs:

root@snowboarder logs]# tail info.log

2006.06.09 12:18:56 Server halted

2006.06.09 12:19:13 Started server (unencrypted) socket on port: 5269

2006.06.09 12:19:13 Started plain (unencrypted) socket on port: 5222

2006.06.09 12:19:20 Started SSL (encrypted) socket on port: 5223

2006.06.09 12:19:20 Publish-Subscribe domain: pubsub.snowboarder.topica.com

2006.06.09 12:19:20 Multi User Chat domain: conference.snowboarder.topica.com

2006.06.09 12:19:20 Wildfire 2.6.2

2006.06.09 12:19:36 Admin console listening at:

http://snowboarder.topica.com:9090

https://snowboarder.topica.com:9091

tail stdoutt.log

Wildfire 2.6.2

Admin console listening at:

http://snowboarder.topica.com:9090

https://snowboarder.topica.com:909

It seems from all tests that the server is listening on the designated ports…however still getting denied…

How would I go about resetting the admin password…I tried doing that via mysql…however this does not seem to help…

Thanks,

John Dworske

Hi John,

I assume you did edit the JIVEUSER table and did insert a new plaintext password for “admin”. You must purge the user cache, wait 6 hours or restart Wildfire as it caches the read database values for some time.

LG

Yes…I did edit the jiveUser table:

mysql> select password from jiveUser where username = ‘‘admin’’;

*----


password

*----


password

*----


1 row in set (0.00 sec)

And now it looks like this (above)…however still not able to log on…before I edited that table the plain text password was set to NULL…same for all users…

Since the admin logon to the Admin Console was working before…I am assuming that it does not use the plain text password…but rather the encrypted one…

ughh…sorry bout the confusion…but it is driving me mad…I am at a standstill cause can’'t get onto the Admin Console…

Thanks,

John Dworske

LG,

How do I purge the user cache…?

Thanks,

John

Hi John,

without access to the admin console ( Cache Summary) you have a chicken-egg problem - either wait 6 hours or restart it.

I wonder if you need to remove the encrypted password … but you can do something else if you have a user which has a known password. Copy its ENCRYPTEDPASSWORD value to the one of admin and then admin will have the same password.

LG

LG,

You rock man…that was trick that worked…I am now able to get into Admin Console…

I havce been on a wild goose hunt for couple of days trying to figure this out…I thought it was something else that was causing my problems…

Anyhow thanks a million…

Thanks again,

John Dworske

Thanks for all the help…

Dworske