powered by Jive Software

Problems with Jingle

I cannot get Jingle to work at all. I’‘ve read docs, I’‘ve tried fresh installs. Still cannot get it to work. I’‘ve tried on Vista and 2003 server. Hasn’'t worked on either yet.

This is all local. The server has the windows client installed and we can text chat on it just fine but every time we try to use Jingle to make a computer to computer call, there is about a 10 second delay and then the following error pops up on the person’'s window that tried to initiate the call:

Session closed due to unable to negotiate session. This may be caused by firewall configuration problems.

My issue here is that since we’‘re all on the same network, there should be no firewall configuration issues as we’‘re all behind the firewall. However, I’'m willing to open some ports for this to work, however I do not see any listing of ports that the Jingle addon uses.

Does anyone have a list of the ports its trying to use or another solution otherwise?

We’'ve never had an issue with Jingle.

The difference between IM messages and Jingle is that Jingle is a client -> client protocol. The server just sets up the call.

Therefore, if the clients themselves have firewalls, they will not necessarly be able to talk to each other. One solution to this is to use a Media Gateway on the Openfire Server.

From here I’'d suggest you:

  1. Look at the traffic sent from the client using Spark. It should show what ports the client suggest you use.

  2. Turn off the local firewalls in order to ensure they are the issue.

D

hi, I have the same problems. and i have tried all the ways that i found in the forum.for example,

setting Media Services, 2 ips in stun settings.

but all is failed. still have the error:

“Unable to negotiate session.This may be caused by firewall configuration problems.”

1\ i have checked that there is no local firewalls .

2\ i have tried Gtalk,It’'s all OK in my test enviroments.Gtalk also use jingle.

who can tell me how to solve the problems.thanks.

by the way

Deejay:

i don’'t know where to Look at the traffic ,plz tell me the detail, thanks a lot.

Hi Deejay,

Have you find a soultion to this problem? If yes, then can you share it with me. Also, how has been your expernce so far with Jingle’s voice session setup? I am working on a project in which I am required to support PC-to-PC voice calls.

Any help will be much appreciated.

Best Regards,

Nitin

造成此问题的原因是从接收方返回的Jingle包中含有发送方的IP地址,需要把本地的IP过滤掉。

Translation for the upstair:

The reason causing that problem is the jingle packet return from the receiver contains the sender’s ip addr,need to remove the ip addr.

Ha,that is translated by computer and just a little modification.Hope it useful and someone could fix this.