powered by Jive Software

Problems with Search plugin

  1. Search plugin became case sensitive

  2. Search pugin shows in result JIDs only. Other fields are empty at all! All fields in user profile and in server are filled. It doesn’t depend on language, I tested it in English too.

OF 4.6
CentOS 8
PostgreSQL 13
JAVA 11 (1.8.0_202 Oracle Corporation – Java HotSpot™ 64-Bit Server VM)

The problem doesn’t depend on Spark platform (mac-pc) or version (2.6.3 - 2.9.2)

Are you saying it was not case sensitive with older version of Openfire / Search plugin, but using the same Spark version? Because i thought it was Spark’s issue and filed this ticket https://issues.igniterealtime.org/browse/SPARK-2048

I am sure it is not Spark’s fault. I thought so too when I had a test server, but there’s opportunity that happened after our ancient main server (OF 3.8.5) died recently. Now I can get much more information than before :slight_smile:

I have here several Spark versions, from 2.5.8 to 2.7.1, but mostly 2.6.3 and. 2.7.1 all worked fine with search with OF 3.8.5 and now they don’t.

You are right and there was actually already a ticket for that https://github.com/igniterealtime/openfire-search-plugin/issues/10

Oh, it’s not a bug :frowning: Needs a selectable option then! I got here about 1000 users who are very confused with that.

UPD: And there’s still a problem №2, which I believe is not a feature :slight_smile:

I’m not sure i understood you :slight_smile: Maybe this is not a bug, but there is a place for improvement here (make it not case sensitive and not unicode sensitive).

In Problem №2 I meant that search result gives only JID, other fields are always empty (no matter what symbols are there in profiles: latin or cyrillic)

Are you using AD/LDAP? Then it sounds like https://issues.igniterealtime.org/browse/SPARK-2106
Although now i start to think this also might be an issue with Search plugin.

No, I have PostgreSQL 13 db and I create users manually without LDAP/AD.

When I had a testing server with OF 4.3.0 + PostgreSQL 12 + Spark 2.8.3 it was the same result, so that’s why I think on Search plugin. I tried to run old Search 1.5, but it doesn’t want work with new OF at all