powered by Jive Software

Prompted for Admin password when installing Openfire 4.1.1

I’m installing Openfire for the first time on a Windows 2012R2 server. I’m using embedded database, and default to store users. It takes me to the admin password part of the set up, but admin is not the password like stated. I found OF-1167 which seems to have matched my issue saying it was fixed in 4.1.1, but this is what I’m installing. Anyone know of a fix?

Not a first report i’m seeing about this, but i can’t seem to reproduce it. I’ve tried to install 4.1.1 on WS2008, on Win8.1 (should be similar to 2012R2) and it runs ok for me without asking for previous password. Are you installing into Program files? Do you run Openfire via Run as administrator then?

2012r2 is a pain. its really stepped up the UAC.

As wroot stated, running “as administrator” or installing and running as a service should resovle this. Also installing to c:\openfire or somewhere outside program files should work as well.

Thanks for the updates! I was installing it into the default program directory of Program Files (x86). I was logged in as Administrator, but I will try both suggestions, I will “run as administrator” and install into C:\openfire. I’ll update the thread and let you know.

Eventually you will want to install service for it and then it doesn’t matter anymore. This is only important when running it with a launcher. Actually when i setup Openfire i never even run launcher and install and run service and then complete setup by going into http://localhost:9090

I did the initial install to c:\openfire, then installed the service as suggested and going to complete the setup by going into the localhost:9090. No longer is the admin password an issue anymore. Thanks again for all the help, now I can continue setting up and testing.