Public web address - hide port

I am trying to use a easily remember web address instead of the full address that includes the port number for web users to sign onto sparkweb. What is the easiest way to do this? I think maybe host headers might do this but I am not sure. This is what I am trying to do:

Here is the link that works:

would like to send this link to users:

Any help would be appreciated.

Sparkweb can be hosted on just about any webserver. The fact that you are using red5 may complicate matters some. The fact that any html server can host SparkWeb means that as log as you are not use openfire’s jetty server you could give it a standard port 80 name and it would resolve.

This is on the same server as the Openfire server. So I take it changing the http bind port to 80 in the Openfire Server settings would not work.

Your config of spark web should contain the port address with the javascript contained in the index.html for sparkweb :

As Todd has indicated, The Red5 version of SparkWeb forces you to use the http-bind port of the Openfire Jetty web server which by default is 7070. You can change it to any other free HTTP port like 80. You can also change the web application name from red5 to any other name like “im” for example from the admin web console. You can then edit index.html in the root of red5 folder to redirect to sparkweb/index.html instead of red5.html.

This means your users can use

Not exactly what you want, but much better

I think that would work fine. Let me test and I’ll reply back with any questions. Thank you.

with hiding port and using sparkweb with red5, our standard 80 and 443 are not free. used by other stuff. how do I secure http-binding with hiding port? we are using centos and apache. Can we add secure http-binding to apache conf file? example: https://server-name/red5 and this goes to red5’s sparkweb.

I got the address down to:

I am stuck at changing the http-bind port. I try to change it in the Openfire console to 80 and get an error:

An error has occured configuring the HTTP binding ports, check the error log for more details

the log that looks revelant:

2008.12.08 23:05:48 [org.jivesoftware.openfire.admin.http_002dbind_jsp.handleUpdate(http_002dbind_j] An error has occured configuring the HTTP binding ports Permission denied

I checked with netstat and nothing appears to be using port 80.

I also did not see if I need to change anything with Red5 in order to have it connect to the new http-bind port (once it is changed over to port 80) or do I use the rtmpt option?

Thanks for all the help.

I got the same time. my ports 80 and 443 are already taken. I am researching proxy modules for apache. I am more looking at a secure http-bind. If anyone know anything about this or secured and hidden their red5 secure port, please let us know. I will report back what I find.

I am not a Linux person, but I suspect you need root or some special priviledge to listen on low ports like 80. On the other hand, I might be talking utter rubbish

Hey members,

Is there an Apache like mod for jetty to mask urls like mod_rewrite OR Redirect permanent. This would help me since I use Apache rather than Jetty or TomCat, could this be the fix for the issue as well?