Question on adding a date to the recorded conversations?

IS there a way to add date and time in spark or in the DB so that when we run the queries then along with the body of the conversation we can get the Date and time of when that conversation took place? This is all in the embeded DB.

Any help on this topic is appreciated.


In spark you can turn on the preference to show time in the chat window. As far as I know all chat logs contain the date and time stamp by default. It is just a matter of having the right tools to read that part of the stored data.

Thanks, let me try that out and see if it actually shows up in the DB.

Also another question I had was regarding the S2S is there a way to enable it… I did it in openfire but i’m still not able to send a message to my user using another server.

Please let me know what i’m missing and what i need to fix.


you need to add that user to your roster and they need to add you with the full JID ( You may also need to accept their invitation. If you have the subscription plugin installed it needs to be configured to accept local, accept all will not work for S2S.

Hi Todd,

Thanks for the reply. It almost worked. I added the users to each others rosters in openfire and added the users in spark. But for some reason none of them show up as online. When I try to chat I get the “user cannot receive the messages offline?”… our DNS is set up properly for the forward addresses of each other… but for some odd reason they dont seem to communicate.

So after adding the users to each other and adding their rosters they dont seem to come online. on occasion One of them comes on. Regardless of the status we can still ping each other by name and by IP.

Let me know your thoughts on this.


Can you detail exactly how you are adding the users to the roster? Also is the server accessible to the outside world.

Hi Todd,

To list out the details. To add users to a Roster I first create a Roster in Openfire under that user (under users/groups and then selecting my user). Therefore, as an example I first add User2 (JID) to my user1 roster in Openfire and then add user2 (JID) to my spark client for user1.

Then I do the same process to add user1 to user2 roster in openfire first and then spark.

So one of the users shows up online… But when I start my conference or single chat they dont see eachother and apprear offline in Spark Client.

Therefore I’m not sure if i am not adding properly or if there is a feature in Spark that i need to enable to allow this but its not working properly.

Please let me know if you need more clarification, or if you can provide more clarification…


You should not be doing anything in openfire at all. That is probably your problem. You should add th users in your roster via spark. Anything you add in spark will be transfered to openfire.

ScreenShot007.jpg ScreenShot008.jpg

I tried it both ways (1. Just through Spak. and 2nd way with Openfire and Spark). Anyway i’ll try this agian with creating new users (in both of my domains/networks) and then adding them through just the spark client and see if it works.

But so far the issues might be something else. The users show up on each others list (eventhough they are on a different domain) just because I added them but they appear in the offline list. and on the one it show online but pending approval and when I check the user that has to approve the acceptance he doesn’t see anything like “accept or reject or anything”.

Also when I click on start a chat and view their profile I can see their profiles on both domains, but I can only see client version for one of them on one domain only.

Both of my JID’s can ping eachother, from different networks.


I wish to continue to assist you with this but this seems like a firewall or openfire configuration issue.

Does you Server to Server settings in openfire look like this:


Do you have the appropriate port opened in your firewalls/routers (port 5269).

You should alway be asked to accept a user when they try to add you to their roster.

Yea our screens look the same… i’ll double check the port but as long as I can remember its open.

Yea it seems to be a firewall issue.

i think my problem is something to with the dns lookup error. when i chek the log file it always gives me the javanet host unknown error…

under connection to server session i dont have any active sessions… between two networks this is what seems to be the issue…

i’ll post the logfile soon!