powered by Jive Software

Questions about .war file, jetty, jboss

I have a few questions about war deployment

  1. When I deploy the war file to jboss, the jetty web server is also started. How do I disable jetty web server in this case?

  2. When use the war deployment, is wildfire server still a standalone server? or it runs inside servlet container?

Can someone explain the architecture of .war deployment?

  1. When I deploy the war file to jboss, the jetty web

server is also started. How do I disable jetty web

server in this case?

How do you confirm that the jetty container is actually started? I made a quick test with jboss-3.2.6 and could not see any evidence of jetty. Could it be you are running jboss with jetty instead of tomcat? localhost:8080 throws up the standard jboss web interface for me.

AFAIK when deploying as a WAR jetty is not used - the servlet container of the web server is used i.e. resin, tomcat, jboss.

  1. When use the war deployment, is wildfire server

still a standalone server? or it runs inside servlet

container?

It runs inside the servlet container not standalone. However it needs a reference to some file system resources such as wildfire.xml, plugins directory and optionally embedded db. This is determined by setting up the wildfire home.

Can someone explain the architecture of .war

deployment?

Identical to the standalone except you provide the servlet container and need to setup wildfire home. Have a look at this kb doc.

I really think it needs some improving to make war deployment easier.

Hope that helps,

Conor.

Thanks for your help.

I’'m using Jboss 4.0CR2. The only thing I did to make it working was to add “-DwildfireHome=C:
wildfire” as jvm options to jboss.

When I started jboss and copy wildfire_2_6_2.war to jboss’'s deploy folder, I got this from the jboss console:

17:33:04,244 INFO Version Jetty/5.1.x

17:33:05,416 INFO Started org.mortbay.jetty.servlet.WebApplicationHandler@6a2a2b

17:33:06,338 INFO Started WebApplicationContext[/,Wildfire]

17:33:06,338 INFO Started org.mortbay.jetty.Server@1afa94

17:40:21,900 INFO Admin console listening at:

http://myserver.com:9090

https://myserver.com:9091

Also I can access admin through both http://localhost:8080/wildfire_2_6_2 and http://localhost:9090/. This indicates Jetty is running.

On my web browser, if I access through port 8080, I can see Appserver is “Apache Tomcat/5.5.16” in the admin panel. If I access through port 9090, the AppServer is Jetty/5.1.x.

Is there anything else I need to do to disable jetty?

Another thing is, if I copy wildfire_2_6_2.war to jboss’‘s deploy folder before jboss starts, it will throw exception “java.lang.ClassNotFoundException: No ClassLoaders found for: org.mortbay.log.Factory”. I have to copy the war file to jboss’'s deploy folder after jboss is started.

Hi Dan,

which wildfireHome are you using? One where a normal Wifi installation was running before? My wildfire.xml file sets both admin ports to -1 and my plugins directory does not contain an “admin” folder.

LG

wildfire.xml

/code

I replicated your problem, its as it2000 suggested!.

The solution is to remove the admin folder from inside your c:
widlfire
plugins folder as per the kb article.

You will no longer see the jetty container output.

Cheers,

Conor.

I’'ve just had a clean install from wildfire_2_6_2.exe (I used to use wildfire_2_6_2.zip). Here is what I did:

  1. Delete previous wilefire files

  2. install to c:\wildfire from wildfire_2_6_2.exe

  3. Start jboss

  4. copy wildfire_2_6_2.war to jboss’'s deploy folder

Here is what I get from jboss console:

12:32:05,232 INFO Version Jetty/5.1.x

12:32:05,248 INFO Checking Resource aliases

12:32:06,076 INFO Started org.mortbay.jetty.servlet.WebApplicationHandler@9e49c0

12:32:06,951 INFO Started WebApplicationContext[/,Wildfire]

12:32:06,951 INFO Started SocketListener on 0.0.0.0:9090

12:32:06,951 INFO jetty.ssl.keystore=C:\wildfire\resources\security\keystore

12:32:07,591 INFO Started SocketListener on 0.0.0.0:9091

12:32:07,607 INFO Started org.mortbay.jetty.Server@3729c5

12:32:07,670 INFO Admin console listening at:

http://127.0.0.1:9090

https://127.0.0.1:9091

In c:\wildfire\plugins, I can still see the admin folder. Also in c:\wildfire\lib, most of jar files are with .pack extension.

If I manually modify wildfire.xml to set both admin ports to -1, and startup jboss again, I get this:

13:33:47,013 INFO Version Jetty/5.1.x

13:33:47,045 INFO Checking Resource aliases

13:33:47,841 INFO Started org.mortbay.jetty.servlet.WebApplicationHandler@148a9f6

13:33:48,685 INFO Started WebApplicationContext[/,Wildfire]

13:33:48,685 INFO Started org.mortbay.jetty.Server@bee95a

13:33:48,685 INFO Warning: admin console not started due to configuration settings.

So jetty is still started but with port disabled.

Hi Dan,

that’'s the bad way to get started with the war file. Maybe Jivesoftware can add a wildfireHome directory to the war file download so it gets more easy to start and also a link to Installing Wildfire as a web application[/url] so one can read Make sure that the wildfire home folder does not contain an admin folder under the plugins folder.[/u][/i]

LG

Sorry I didn’'t notice "wildfire home folder does not contain an admin folder under the plugins folder. ".

It works now. Thanks a lot.