powered by Jive Software

Quick, Is my HTTP-Bind working correctly?

I am using the newest version of OpenFire, and I was wondering if my HTTP-Bind was working correctly. (I Have enabled it in the Admin console panel).

I go to http://localhost:8080/http-bind/ and I get the following page:

HTTP ERROR: 404NOT_FOUND

RequestURI=/http-bind/

Powered by Jetty://


Does this mean it doesn’t work? If so, how do I solve this problem?

Can anyone confirm this?

No, it should show you some text mentioning http binding.

Make sure you enabled http binding in your Openfire server, and that you actually use the /http-bind/ alias.

I have enabled HTTP Binding on port 8080 in the server. I have confirmed this by going to System Properties and it displays this value:

httpbind.enabled

true

However, I have do not know how to use the /http-bind/ alias. How do I do it? Also, what else should I do?

If anyone else can help, please do so. I am willing to compensate for the time spent on resolving this problem. I have been trying to fix it for a while, whenever i disable http-binding from the admin panel, http://localhost:8080/http-bind/ doesn’t work, but when I enable it, it gives me a 404 Error. Anyway to fix this?

I checked again with our OF server - try the address http://localhost:8080 - that should give you something about http binding, adding the alias does give me a 404 too.

The /http-bind/ is only for JWChat

When I go to http://localhost:8080 IN THE WEB-BROWSER (IE7)

It gives me:

HTTP ERROR: 404

NOT_FOUND

RequestURI=/

Powered by Jetty://

I get the same 404 “NOT FOUND” error in my browser, When I go to http://localhost:8080/ using Openfire 3.4.2

I downgrade my version to Openfire 3.4.1 and now when i go to http://localhost:8080/ , i can see a webpage that says http-binding. I could also configure a /jwchat and a /jeti directories, just copying the files under the \resources\spank subdirectories in Openfire Home, then i get some http services from there (Openfire in this case works like a Web Server i didn´t need Apache or Tomcat):slight_smile:

Using 3.4.2 i could not do this…

I get the same error-message with Openfire 3.4.2 and 3.4.3. Http-bind is definitly enabled.

What can I do? Did you find a solution dsanghera?

Apparently, 3.4.1 and prior versions do not give this error, only the new versions do. And I am pretty sure the HTTP Binding is enabled, it just doesnt say anything. Let me know if this is correct.

Hi,

i have the same problem as you described above.

i am running openfire 3.4.3, http-bind is def. enabled but i get a 404.

i also trie with of 3.4.2 - the same.

what is wrong?

I do not know whether this is the correct answer or not but, apparently it works if an XMPP request is sent to it, but not an HTTP request. Which I think makes no sense because it is an HTTP BIND, so it should be responsive to HTTP requests. I think it might be a major bug that we should maybe report?

Do you have anything in the log-files?

Do you using th red5 plugin?

I am also discussing the http-bind error with red 5 in this thread: http://www.igniterealtime.org/community/message/163018#163018

You need to be posting data (<body …></body>) according to the XMP Protocol in order not to get a 404 on this page. According to the protocol, I believe the 404 error indicates that you’re not providing an sid/rid and/or not trying to authenticate. So you get the NOT_FOUND 404 page.

After upgrading from 3.4.2 to 3.4.3 I have lost the ability to access the admin console…

I get that same 404 error when i go to http://127.0.0.1:9090 (i changed mine because 8080 is already used on that server):

HTTP ERROR: 404NOT_FOUND

RequestURI=/

Powered by jetty://

Hey rene-1,

my logs dont give any hints according this problem. There is not even a short note neither in the errorlog nor in warninglog.

At least jwchat is now loading without the errormessage “Service unavailable”. Anyway the it doesnt load any data. So my buddylist is empty.

By the way: to install jwchat was my main goal enabling http-binding.

You made a seperate jwchat install?

Maybe ill do also… but: how do you did it?

Hey rene-1,

finally I got jwchat running. At least the roster is loaded, the buttons arent working, but thats not related to our http-bind problem.

So what did I do?

  1. Working with jwchat1.0B3 I deleted all language-files and renamed the *.html.html and *.js.js to *.html and *.js So as a result the jwchat directory just contains *.html and *.js files

  2. Afterwards I changed my Virtualserver settings and made sure that following commands are used in this order.

AddDefaultCharset UTF-8

RewriteEngine on

RewriteRule http-bind/ http://127.0.0.1:9099/http-bind/

<Directory server/public_html/jwchat>

Options Indexes +Multiviews

allow from all

AllowOverride All

</Directory>

  1. Then I followed the steps 2 to 6 of this instruction (http://www.igniterealtime.org/community/message/156835#156835 - see post number four)

I guess thats what Ive done. So try to connect via jwchat. You will see the http-binding is working, though an error message is thrown by jetty sending an http-request to the socket.

Right. Thanks for that!

So lets stick back to the main problem.

Can anyone consider why it does not work? Btw: i installed the red5 plugin v. 0.0.12 but it also does not work…

yeah, same problem for me on Openfire

3.4.3

It used to show the contents of openfire/resources/spank/index.html in earlier versions, that is not the case anymore though

Any news on that one?