powered by Jive Software

Red 5 + spark help

Currently I have the latest Openfire, Red5, Spark, and Adobe Flash Player but I’m still having problems getting any type of video to work. I follow the readme instructions bundled with Red5 and I even go to test sites that use Flash player to access the users web cam and still nothing seems to work. I was expecting to see the video feed immediatly after I hit “allow” on the flash settings for it to receive access to my web cam ( which does come up in the flash player webcam dropdown ). Im currently out of ideas so any help is greatly appreciated.

Thanks,

Gervin

Could you try the Red5 test page at http://red5.4ng.net/chat/red5.html and confirm if the 2way audio/video test works. If that works, please try the same page on your server (replace red5.4ng.net with your server name). Another test is to try the test flash application http://red5.4ng.net/chat/publisher.swf on your server.

-dele

Thanks for responding, dele. Gervin and I are still trying to resolve this problem. We have tested our webcams with those links, but the results were the same.

We have tried both rtmp://localhost/oflaDemo and rtmpt://localhost/oflaDemo URI in publisher.swf and allowed the server to access the webcam, but neither Live, Record or Append shows any video feed. Both URI connected successfully. Log shows:

13:17:33:677 - NetConnection.Connect.Success

13:17:55:864 - Started video device Creative WebCam Live! Pro (VFW)

13:18:00:179 - Publish - NetStream.Publish.Start

13:18:00:179 - Publish - NetStream.Record.Start

13:18:04:534 - Publish - NetStream.Record.Stop

13:18:04:534 - Publish - NetStream.Unpublish.Success

The .flv was created, but had 0kb. Ran Adobe Media Encoder with rtmp://localhost/oflaDemo and that worked, but not rtmpt. We are running inside corporate and personal firewall, but that shouldn’t matter if we are using localhost, right? Anyway, we have tried disabling the personal firewall and allowed port 1935, but to no avail.

As a test, we started another webcam application and then Adobe Media Encoder. Sure enough, Adobe Media Encoder complained that the webcam is already in use. But AME did not complain when publisher.swf is supposedly recording.

2way audio/video test showed two gray windows with no video.

Btw, we did have some luck with audio conference using Spark.

Steve

>We have tried both rtmp://localhost/oflaDemo and rtmpt://localhost/oflaDemo URI in publisher.sw

You do realize that this will only work when the browser and RTMP (red5) server are on the same PC. This is not the same as rtmp:/oflaDemo which assumes the RTMP server is the same as the web server from which the SWF file was loaded. In addition, RTMPT by default is port 80 and requires you to configure red5.properties file accordingly. In my setup at red5.4ng.net, RTMPT is port 8000 and I use rtmpt://red5.4ng.net:8000/oflaDemo

Assuming you were running all your tests on the same PC in order to access Openfire and Red5, I can’t see why your video publish/subscribe is not showing unless the video names are different.

My suggestion is that you should first confirm your webcam and Flash player is working with Red5 by using two separate PCs to access the 2way audio/video test first at red5.4ng.net and then on your server internally and externally.

-dele

It turns out the problem is exclusive to our company’s computers only. Since all of our computers were installed with the same image, they all inherited the same problem.

We created a little network with a personal laptop as client connected to the company’s machine, and it (red5) worked, but not vice versa. There’s something with our company’s computers that prevents flash from accessing the webcam. Has anyone else encountered this problem?