powered by Jive Software

Red5 installation for openfire on debian etch // help needed!

Hello!

I tried to get openfire working with red5 on debian etch - not really succesfull

Is there anybody out there who can explain the installation of openfire, red5 on debian?

perhaps we can create a how to - for non linux gods its really hard to understand.

there a lot of how-to documents in the web - but i am not sure they still fit !?

The 3.4.3 openfire debian package itself should install successfully on your debian etch.

Make sure you have sun-java5-jre installed with : #apt-get install sun-java5-jre

download the package without java from ignite downloads and do a simple : #dpkg -i openfire_3.4.3_all.deb

it will install the package and complain if there are package dependencies problems, the only package required is sun-java5-jre so it should not complain if you’ve installed java as described above.

Now in order to use red5 plugin you need to install java-sun-6 which is not part of etch but part of lenny debian version.

There are quite a few ways to do that, one of them being messing up your apt configuration files which is okay as long as you know what you’re doing.

In your apt you can either choose to go for lenny or for debian etch-backports, i would probably recommend to use backports if you’re not confortable with apt commands and distro mixup…

But the safest way is probably to forget about apt and dowload the sun-java6-bin and sun-java6-jre packages from etch-backports : http://packages.debian.org/etch-backports/sun-java6-bin

the problem here is that those backports packages are only available for i386, meaning that if you’re on a debian 64bit version those packages won’t do you any good !

Then you’re need to get your hands dirty playing with apt / lenny or you can download lenny packages the same way you were going to download backports versions : http://packages.debian.org/lenny/sun-java6-bin

But those packages depend on lots of other packages and so on, so you could be in for quite a treat if you’re doing the downloads/installs manually…

I haven’t tried it so i can’t tellif you’ll have to manually upgrade a lot of packages or not… But in any case it shouldn’t break your debian package system and that’s the only thing important to a debian user…

anyways once you’ve downloaded the sun-java6-bin and sun-java6-jre packages from lenny in your CPU version (amd64/i386) you can try to install them using the same command as above : #dpkg -i package.deb otherpackage.deb

You will see right away if other packages are missing and then you never know how long it’s gonna take to get them all…

Now if you want to get a quick shot at installing packages from a different version than your running debian version you can try the following scheme :

in your file “/etc/apt/sources.list” add one line for the lenny packages like this :

deb ftp://ftp.proxad.net/mirrors/ftp.debian.org/ lenny main contrib non-free

replace ftp://ftp.proxad.net/mirrors/ftp.debian.org/ by the part that is present on the existing lines of this same file where it is specified “etch” or “stable” and especially “non-free” which is where the sun-java packages are located.

once this is done edit or create the following file “/etc/apt/apt.conf”, and add the following line in it :

APT::Default-Release “stable”;

Now do a : #apt-get update

And : #apt-get install -t lenny sun-java6-bin sun-java6-jre

It should install / upgrade packages of your debian in order to install those two sun packages…

You can now delete or comment (# at the beginning of the line) the “lenny” line we’ve added to /etc/apt/sources.list above and then do a #apt-get update, once more and you should be safe.

Now there’s quite a good probability that both versions 1.5 (java5) et 1.6 (java6) are installed on your system, in order to know which java version is currently the default one, try a #java -version

It should show you the running java version, if it’s still 1.5 it’s okay we actually don’t need 1.6 to be the default version, if it’s 1.6 it’s okay too, that was just for your information.

Now edit the startup script that openfire 3.4.3 package has installed “/etc/init.d/openfire” and modify the following line near the top :

JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun

so it points to

JAVA_HOME=/usr/lib/jvm/java-6-sun

And finally give it a shot with #/etc/init.d/openfire start

If something goes wrong or nothing happens then please make sure that you have actually installed sun-java6 by looking into /usr/lib/jvm, you should see some java6 directories there, and then if the names are not as above, change the JAVA_HOME in the /etc/init.d/openfire file…

Note that you can alter openfire ports prior to running the first openfire setup, in the file “/etc/openfire/openfire.xml”

Good luck,

.eldon

well that was a short one

thank you very much! i tried it … an i think it is running wiht java6

the only problem is with the path of red5.

http://mydomain:9090/red5 is not workin as described

instead of it i have to use http://mydomain:9090/plugins/red5 to configure it?

what is happening here?

also spark plugin uses the first domain …

you had the same problem?

humm no never had to use /plugins/red5

how did you install the plugin, by uploading it thru the web admin ?

red5 plugin should create a web service using the app name parameter set in red5 plugin admin, which is “red5” by default and that web service should be available at “/red5”…

But most of the time i’m using apache rewrite rules to make all traffic go through port 80 so i never really tested it on the default ports directly…

I’m not using spark so i can’t help you with that sorry.

Ihre e-mail an cms.worxx.de ist angekommen!

Wir werden Ihr Anliegen umgehend bearbeiten, und sofern eine Antwort gewünscht war, mit Ihnen in Kontakt treten!

try http://mydomain:8080/red5

-dele

Ihre e-mail an cms.worxx.de ist angekommen!

Wir werden Ihr Anliegen umgehend bearbeiten, und sofern eine Antwort gewünscht war, mit Ihnen in Kontakt treten!