Red5 on Openfire 3.7.1


I need to setup a Openfire 3.7.1 using the red5 plugin. this was the steps I have done to use the red5 plugin.

  1. stop openfire

  2. put red5.war to plugins folder

  3. start openfire

But when I tried to view the plugin it was not showing in the plugin page,

When I tried to view the logs I was able to see the errors below

2012.01.05 22:23:56 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: C:\openfire\openfire\plugins\red5

java.lang.UnsupportedClassVersionError: Bad version number in .class file

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClass(Unknown Source)

at Source)

at Source)

at$100(Unknown Source)

at$ Source)

at Method)

at Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at org.jivesoftware.openfire.container.PluginManager.loadPlugin( :420)

at org.jivesoftware.openfire.container.PluginManager.access$300( :80)

at org.jivesoftware.openfire.container.PluginManager$

at java.util.concurrent.Executors$ Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$ Source)

at Source)



Seems to me that you are not using the right version of JRE.

Don’t download the red5.war from the beta plugins,

go to

But redfire version dont have the sparkweb A/v module where red5 version has it. is possible to run the red5 version in openfire 3.7.1?